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1. Introduction

The purpose of this document is to provide basic instructions to assist users in converting tabular data files in
.tbl format (Standard NRVIS Interchange Format — SNIF) to the standard dBase .dbf format utilized by ArcGIS
products.

The examples and procedures shown in this document have been created using Microsoft ® Access 97,
Windows XP, and Land Information Distribution Service (LIDS, version 2.1) data.

2. Related Documents

Detailed SNIF Subscription Specifications
SNIF Package Conversion, Base Inventory & Forest Cover

3. General Process: .tbl to .dbf

Data packages obtained from the Land Information Distribution Service (LIDS) contain tabular data in comma
separated values format in files named with a .zb/ file extension. These files can be utilized by any software
application that can handle files in comma separated values format simply by converting the .7b/ files so that
they have a .csv extension. The .¢b! files can be opened using Notepad or Wordpad and saved as a .csv file. This
approach allows you to ensure that wordwrap is not occurring within the .zb/ file.

3.1.Locate and Rename .tbl Files

Extracting the LIDS zip file will create a file and folder structure similar to the one shown below for the
Airport data class:

=l [C) sc20-lio-2004-03-04-113413-27256
|2 common
=1 ) spatial
|2 airport

The .¢b! files containing tabular data are found in the spatial\dataclassname and common folders.

a2 0-lin-2004-03-04-113413-27 2561 spatiallairport

Mame = | Size | Type | Date Modified

1] airport, ok 1KB PCKFile 04/03/2004 11:34 &M
El airpart_airstrip, kbl 74 KB TBL File 04/03/2004 11:34 AM
| alias_name. thl Z7KE  TEL File 0032004 11:54 AM
| geag_unit. thl 121 KB TEL File 04/03/2004 11:54 AM
ol dbr 213KE DEFFile 04/03/2004 11:54 AM
#]paly.pri 1KE PRIFile 04/05/2004 11:54 AM
paly.shp S47KE SHP File 04/05/2004 11:54 &M
paly sk SKE SHFile 04/05/2004 11:54 AM
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3.1.1. Use Windows Explorer to locate .7b/ files. Right-clicking on a file will allow you to select Open
With > WordPad from the context menu.

Mame = | Size | Tvpe
|14] airpart.pck 1KB PCK File
|§| airpork_airstrip, kbl 74 KE TEBL File

B | &is Z7 KB TBL File

121 KB TEBL Fil=
I 213 KR DRF Fils
Open With (28] Microsaft Esccel \

paly shx &3 Add ko geog_unit. zip ) Notepad

Encrypt and Sign

Choaose Prograr. ..

-

Secure for Lisk
Entrust Advanced »

Send To »

3.1.2. Optional: All data values in the .¢b/ file are enclosed in quotation marks which, by default, will be
imported into Microsoft® Access as text fields. At this point you can use the Edit > Replace feature
of WordPad to find and replace the quotation marks (find *“ and replace with nothing). Upon import,
Access with examine each field and try to assign an appropriate field type based on the field
contents. Regardless, proper data field types can be assigned and/or changed during the import
process within Microsoft® Access.

3.1.3. Save the file by selecting File > Save As and then specifying a filename with a.csv extension, as
shown in the example below:

saveas 2|
Save in; IE}airpDrt j &) ? 3 *

File: narme: Igeug_unit.csw{ j Save
Save az type: ITEHt Document j Cancel |
[~ Save in this format by default 4

3.1.4. Once saved, close WordPad.
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3.2.Import .csv files to Microsoft® Access
Microsoft® Access provides tools to easily allow for the conversion of .csv files into .dbf format. The
examples shown in the procedure below illustrate the conversion of the geog_unit.tbl file. Other .¢b! files can
be converted in the same way.
3.2.1. Start Microsoft® Access and select the option to create a blank database.

3.2.2. From the Access menu, select File > Get External Data > Import:

®, Microsoft Access
”l File Edit Wiew Insert Tools ‘Window Help
“ [ Mew Dakabase,..  Cerl4+M

-}

& openDatabase.,. Chrl+O

3.2.3. On the Import dialogue window, change the Files of type option to Text Files and then browse to
locate the geog_unit.csv file and click the Import button:

Lookin: [ arpart &l & alml [ =] B
i Impart |
Cancel |
advanced. .. |

Find files that makch these search criteria:

File name: j Texk or property: I j Eind Mo |
j Last modified: Iany time j Mew Search |

ault, To add other File bvpes, run the Setup program, click Add/Remove, Data Access,
are also available in the Office 97 YaluPack.

Files of type:

Mot all file kypes are installed
Change Option, Additional File

3 File(s) found,
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3.2.4. Ensure that the Delimited option is specified and then click the Next button:

B Import Text Wizard x|

The wizard has decided that your data iz in a 'Delimited’ format. 1F it izn't, chooze the format that
more corecty describes vour data.

Chooze the format that best describes vour data:;

* {Delimited - Characters such as comma or tab separate each field

™ Fixed 'Width - Fields are aligned in columng with spaces between each field

Sarnple data from file: EATEST DATAMSMIF FROM LIDSYAIRPORTASC20-LI0-2004-03-04-1

11 |"FMF_OBJECT_ID", "GEOG_UNIT_TYPE_NHUM" . "GEOG_UNIT_DESC| -
|2 ["50328764" 12200, ", "1997-07-04-00:00:00", "Verified
| 3 ["50846836", 1220, "", "1997-05-13-00:00:00", "Verified
4 |"50846837" . "1220" . """, "1997-05-283-00:00:00". "Verified
|G ["50846839" , "1223" "", "1997-05-13-00:00:00", "Verified
| 6 ["S0846840", "1220", "", "1997-05-13-00:00:00", "Verified
| 7 ["50846841" , "1223" ", "1997-04-30-00:00:00", "Verified
g |"50846842" "1220", " ","199?—05—29—DD:DD:DD","?Erified;l

i
Advanced... Cancel < Back I MHext » I Finizh |

\_E

3.2.5. Ensure that Comma is selected as the delimiter, and click to check on the First Row Contains Field
Names option. Click the Next button:

B Import Text Wizard x|

YWwhat delimiter zeparates your fields? Select the appropriate delimiter and see how pour test iz
affected in the preview below,

Chooze the delimiter that separates vour fields:
’7'[" Tab = Semicalon * Comma " Space (. Dther:l_

I¥ :First Bow Containg Figld Mames Text Qualifier: " -

FMF OBJECT TD|GEOG THIT TYPE HUM |GEQG THTT DESCR |VERETE
50328764 1220 19970 =
S03465836 1220 19971
S0846837 1220 19971
S0346839 1223 19971
S0346540 1220 19971
S0346541 1223 19971
S0346542 1220 19971
S0346543 1220 1‘3‘3?—[:'

i
Advanced... Cancel ¢ Back I Mest » I Finizh |

\_E
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3.2.6. Ensure that the In a New Table option is specified and then click the Next button:

ES Import Text Wizard P

Where you would like to store pour data? You can store it in & new table or in an exizting table,

| would like to gtore my data...

" |n an Existing T able: ]

FMF OBJECT ID |GEOG UHIT TYPE HUM [GEOG UHIT DESCE [VEEIEF
50328764 1220 19970 «
S0346836 1220 19370
50346837 1220 19937—(
50846839 1223 19970
S03460540 1220 19370
S03460841 1223 19937—(
50846842 1220 19970
50346843 1220 1‘39?—[;'

A il
Advanced... | Cancel ¢ Back I Me:-:bi I Finish |

3.2.7. Specify the appropriate field types for the various fields to be imported. By default all fields are
assigned as text (unless the quotation marks have previously been removed using WordPad).
e Select FMF_OBJECT ID and select a data type of double (or long integer)
e Select each of the description fields and specify a data type of memo (otherwise long
descriptions will be truncated at 255 characters)
o Click the Next button when finished

H Import Text Wizard =|

rou can specify information about each of the fields you are importing.  Select fields in the area
below. “Y'ou can then maodify field infarmation in the 'Field Options' area.

Field Options
Field Name: [FMF_DEJECT_ID Data Tpe: [0 =]
Indexed: |Yes [Duplicates OK) ;l [ Do nat im g::;la:q" =
Date/Time
Text
FMF OBJECT ID |GECG THIT TYFE HUM |GEQGH OLE Object
7E 1220 Mema |
1220 Huperlink -
1220 1997—
1223 1997—
1220 1997—
1223 1997
1220 1997—
: 1220 1997 *|
K1 i

Adganced...l Cahcel < Back I Mest > I Finizh I

Converting_TBL_to_DBF_ver_1.doc
Version1.0 issued March 9, 2004
Revised: June 23, 2004



OLIW —File Format Conversion Instructions

B Import Text Wizard x|

You can specify information about each of the fields you are importing. Select fields in the area
below. 'ou can then modify field information in the 'Field Options' area.

— Field O ptions
Field Name: [GEDG_UNIT_DESCR Data Type: [ ]

. .| Currenicy =
ndexed: |ND =] T Donatim Single

Double
Date/Time
Teut

OLE Object

Huperlink, ' - —I

ao:o0:00 [Verified
1997-05-13-00:00:00 [Verified
1997-05-13-00:00:00 [Verified
1997-04-30-00:00:00 Verified
ao.o00:00 [Verifiied
1997-05-29-00:00:00 Herified):]

B N i
p‘-‘-.dganced...l Cancel < Back I Mewt » I Finizh |

3.2.8. Specify No Primary Key and click the Next button:

3 Import Text Wizard |

Microzoft Access recaommends that you define a primary key for
= your new table, A& primary key iz uzed to unigualy identify each
. T record in your table. [t allows pou to retrieve data more quickly.
P ] o
T i " Let Access add Primary Key.
FAREEE R ' g -
 —— Chooze my awn I‘:'nrnar_l,I k.ey. _|

FMF OBJECT ID [GEOG UHIT TY¥PE HUOM |GEOG THIT DESCE |[VERIE
50328764 1220 19970 &
50846836 1220 1997
50846837 1220 1997
50846839 1223 1997
50846540 1220 1997
50846541 1223 1997
S0846842 1220 1997
50846543 1220 199?—[;'

A i
.-'-‘-.dganced...l Cancel ¢ Back I Mest > I Finizh |

Converting_TBL_to_DBF_ver_1.doc
Version1.0 issued March 9, 2004
Revised: June 23, 2004



OLIW —File Format Conversion Instructions

3.2.9. Click the Finish button:

B Import Text Wizard x|

That's all the information the wizard needs to import your data.

Import bo T able:

[Geog unif

[ 1 would like a wizard to analyze my table after imparting the data.

™ Display Help after the wizard iz finizhed,

.-'-‘-.u:lganu:ed...l Cancel ¢ Back [Hent | Einishi I

3.2.10. You will be notified that the import to the Access table is complete. Click the OK button:

Import Text Wizard |

\ij) Firished importing file 'E: Test Datal SMIF Frarm

LIDSh airportl sc20-lio-2004-03-04-1 1341 3-27 2560 spatiall airportigeog_unit.csy' to table
‘Geng_unit',

3.3.Modify Table Field Names

After the .csv file is imported into Access, the field names must be shortened to the maximum 10 characters
allowed in a .dbf file before creation of the .dbf file. The export utility will automatically truncate to shorten
the field names. However, the truncation will cause for duplicate field names and prevent creation of the .dbf

file.
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3.3.1. Highlight the table name on the Tables tab and click the Design button.

gHe airport : Database -0l x|

Ed Tables | Queries | Farms | B Reports | I Macros | & Modules |

Qpen

Design

Jf

3.3.2. Change each of the field names so that they are no longer than 10 characters. Close the design
window and save your changes when finished.

Note: A standard list of recommended shortened field names is provided in the document SNIF
Package Conversion, Base Inventory & Forest Cover.

B Geog_unit : Table

Field Mame Data Tvpe
| |OBI_ID Murnber
| &7 _MurM Text
| |EEDG UNIT Mema
WARERIF STATUS DATE Texk
| [VERIFICATION_STATUS_FlLG Text
| |LOCATION _DESCR. Mema
| |LOCATION _ACCURACY _CODE Text
| [GEMERAL_COMMEMNTS Memo
| [BUSINESS_EFFECTIVE_DWATE Texk
| |BUSINESS_EXPIRY_DATE Text
| |BUSINESS_EFF_DATE_FLG Text
| [PRESUMED _REAL_IMD Texk
| [DATA_SEMSITIVITY _IMD Texk
| |MATIVE_IMD Text
| |SYSTEM_CALC_METRIC Text
| [USER_CALC_AREA Texk
| |EFFECTIVE_DATETIME Texk
| |EXPIRY_DATETIME Text
| |EXT_EFFECTINE_DATETIME Text
| |EXT_EXPIRY _DATETIME Texk

3.4.Export Access Table to .dbf Format

3.4.1. From the Access menu, select File > Save As/Export. Make sure that the option to save To an
External File or Database is selected and click the OK button.
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saveas.. 21 x|
—Save Table 'Seog_unit!

{* To an External File or Database
Cancel

™ Within the Current Database as

ewilame: | Copy of Geog_unik

3.4.2. Change the Save as type to dBASE 5 and click the Export button.

Save Table "Geog_unit" As ilil
Save in: I":' Test Data j | | EF' e
| inesting Export I
) SMIF From LIDS

Cancel |

[T save

Formatted

[T Autostart

=

& all
" Selection

File name: IGEDg_unit LI

Save as type:| FEEEAHM—— |

Mot all File bypes are inskalled by default. To add other file bvpes, run the Setup program, click Add/Remove, Data
frccess, Change Option. Additional file bypes are also available in the Office 97 YaluPack.

A copy of the file has now been saved as a .dbf file.

4. Converting a dBASE .dbf File to an Info Table
If ArcINFO tables are required, they can easily be created from a dBASE .dbf file using the ArcGIS
ArcToolbox conversion tools. It is recommended that the ArcToolbox help be consulted for more specific
information concerning issues such as data type mapping and conversion, and conversion limitations
between the two file types.
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4.1.General Process: dBASE to INFO

4.1.1. Start ArcToolbox and double-click to start the dBASE to INFO conversion tool (found under
Conversion Tools > Import to Table):

% ArcToolbox - ArcInfo

Tools  Help

Elé Conversion Tools

4 ahout Conversion Tools

+- i Export from CAD

‘ Export From Coverage
‘ Export from Geodatabase
‘ Export from Raster

; ‘ Export From Shapefile
@ Export from Table

‘ Export fram Tin

+ ‘ Import to Coverage

‘ Import bo Geodatabase
‘ Import to Raster

: Import to Shapefile

3 Imnport ko Table

: € about Import o Table
dBASE to IMFO
- g#* DBMS o INFO

J

-

Converts a dBASE [*.dbf] table to an IMFOD table. ;I

14

4.1.2. Browse to specify the location of the input dBASE table and the resulting output INFO table

(specific requirements for field mapping can optionally be specified here). Note that the location of

the output INFO table must be in an existing INFO folder. Click OK when finished.

= Field definitiar

Decimal places: &

Input dBASE table: [E:\Test_D ata\GEDG_LINLdbf g

Data type mapping: % Default mapping ¢ Define mapping

2=

dBASE field:  |OBJ_ID

Field name; OBJ_ID |temn narme;
Figld width: 19 Itern width:
Duatput width: 19 Clutput width:
Field type: Double [tem tpe:

Decimal places: |5

Dl

IFIDating point VI

Output IMFO table:  |E:\Test_Databgeog_uni

Batch = |
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