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Before You Begin

About this Book
This book, the Beyond 20/20 Browser User’s Guide, explains the capabilities of
the Beyond 20/20 Browser, and teaches you how to browse Beyond 20/20
tables and create new tables using Beyond 20/20 extracts.

To use the Browser and to make the most out of this book, we assume that:

• You have access to Microsoft Windows on your workstation and are
familiar with its operation.

• You have access to all of the Microsoft Windows user’s documentation.

• The Browser has been installed on your workstation, and its operation has
been verified by searching for, and accessing, the sample Beyond 20/20
table files PEOPLE.IVT and PRODUCTS.IVT, and the sample Beyond
20/20 extract files SURV.IVX and SURVF.IVX.

What is in the Book
This book is comprised of the following chapters:

This section, “Before You Begin,” provides an overview of this book. It
explains the assumptions that were made in preparing the book, and introduces
you to the information in it.

Chapter 1, “Working in the Browser Window,” introduces you to the Browser −
a Windows-based program for browsing and creating Beyond 20/20 tables. It
gives you an overview of the Browser and summarizes its menus and file
system. It also describes parts of the Browser application window and how to
change the appearance of the application window.

Chapter 2, “A Quick Tour of the Browser,” gives you an idea of the kinds of
things you can do with the Browser. It demonstrates the most common browsing
and extract activities, and familiarizes you with the Browser’s physical and
functional characteristics.
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Chapter 3, “Finding and Opening Tables and Extracts,” guides you through
searching large volumes of information and focusing on the data you want. This
chapter explains how to find relevant tables and extracts quickly when you are
not sure where to begin.

Chapter 4, “Browser Basics,” explains how to change appearance of the table
view and describes various browsing techniques.

Chapter 5, “Working With Data,” explains how to change the way data is
displayed in a table view. It also provides information about worksheets,
importing, saving, exporting, copying, and printing data.

Chapter 6, “Charts,” describes how to display a chart that is based on the data
you select from the columns and rows of a table. Sections about how to format
and style the chart view are included.

Chapter 7, “Maps,” describes how to display table data in a map. The chapter
includes information about how to interpret the view, and how to change the
map options.

Chapter 8, “Extracts,” describes how to create your own tables from an extract.
It also describes how to create custom table dimensions based on source fields
from the extract.

Chapter 9, “Customizing Tables and Extracts,” explains how to make a table
more informative. Activities such as adding groups, creating fields and labels,
saving views, and documenting a table are covered.

A Word about the Beyond 20/20 Demonstration Files
Two table files, PRODUCTS.IVT and PEOPLE.IVT, and two extract files,
SURV.IVX and SURVF.IVX (the French version of SURV.IVX), are distributed
with the Beyond 20/20 Browser. These files are featured in the examples
throughout this book.

Conventions in this Book
The conventions used in this book are similar to the ones used in the Microsoft
Windows user's documentation. As you go through the book, you will notice
that the following text conventions are used:

Convention What it means

Bold Highlights tips and notes.

CAPITALS Gives the names of dimensions, and Beyond 20/20 tables
and extracts.
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Convention What it means

Initial Capital Highlights proper nouns such as: window titles, dialog box
titles, dialog box options, menu names, command names,
button names, icon titles, and application program names.

À The stylized arrowhead indicates where a Browser
procedure starts. Browser procedures contain numbered
instructions for you to follow.

Using What You Already Know
If you are already familiar with Microsoft Windows, you will find the Browser
easy to use. The Browser incorporates many of the same features, so you will be
able to navigate the display based on previous experience. Any spreadsheet
experience you have will be put to good use too; the Browser integrates many
of the same concepts, so you should feel right at home.

Because the Beyond 20/20 Browser has a windowing interface, the instructions
in this book assume you will be using the mouse pointer to select objects and to
choose commands. However, the Browser also supports Microsoft Windows key
combinations and key sequences to make selections, choose commands, and
navigate within the Browser window.

Instead of opening a menu and choosing a command with the mouse pointer,
you can press a key sequence to open a menu, and you can press a key
combination to carry out an action. You can also use key combinations to select
dialog box options. Your Microsoft Windows User’s Guide describes the
keyboard techniques in detail.

Using the Browser On-line Help
The Browser On-line Help can be accessed after you start the Browser. You can
open its contents by choosing Contents from the Help menu. To choose a topic
from the Contents list, click on the topic name. Alternatively, pressing F1 at any
time provides you with context sensitive help.

Finding Help Quickly
The Browser provides you with a number of ways to find information quickly.
You can choose the way you like best.
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Searching by Subject

The Search function is the most widely used feature for finding information
about a particular subject in the Browser On-line Help.

To access the Search function once you are in the Browser On-line Help
window, click the Search button at the top of the window.

The Search function lets you specify a word or phrase that relates to the subject
you want more information about, then it links the subject you have specified to
the relevant section(s) in the Browser on-line documentation.

At this point, you can select the section that is most likely to have the
information you are looking for. It is the quickest way to find the information
you need at random.

While You are Using the Browser

You can access context sensitive help even while you are using the Browser.

For menu commands, select the command and, while holding down the left
mouse button, press F1.

For dialog boxes, when the dialog box is open, press F1 or click the Help button
in the dialog box (if one is available).

What is New in the Browser 5.0
There are a number of new features in this version of the Beyond 20/20
Browser.

Summary Indicator

The existence of dimension and item summaries is now indicated by an
underlined dimension name or item heading. To access a summary, double-click
on the underlined name or heading.

Summary Dialog Boxes Display an HTML Viewer

Summaries are now displayed in an embedded HTML viewer. Any underlined
text in the summary notes represents a link to another application, file,
document or web page on the Internet.

Edit Summary

There are Edit File Summary, Edit Dimension Summary, Edit Item Summary,
Edit Extract Summary, and Edit Source Field Summary commands which
invoke the version 4.1-style Summary dialog boxes.
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Table Titles

The limit for the Title in the Summary dialog box is now 255 characters.

Computed Groups

Computed groups allow Browser users to create items by applying basic
arithmetic operations on existing items. For example, one item can be divided
by another and multiplied by 100 to create a new item that contains
percentages.

Define Group

There is a message box asking "Do you want to calculate now?" after the
Define Group command has completed processing an Total or Computed
Group. This message does not appear for Protected Groups. Selecting Yes will
immediately calculate all groups.

Dimension Profiles

A dimension profile is a subset of items from a particular dimension that is
given a name and is stored in a profile file (*.ivp). Profiles are used to quickly
recall a frequently used selection of items. When a profile is loaded, users can
either select or show the items belonging to the profile in the table view.

Number of Items Along a Dimension Expanded to 64,000

Browser users can now work with dimensions that contain up to 64,000 items.

Language Button

The Language button simultaneously switches both the language of the table
and the user interface from English to French or vice versa. The Language
button combines the functionality of the Change Language command and the
Preferred Language option in the Preferences dialog box. The Language button
can be found on the Beyond 20/20 toolbar.

Decimal Places

Items along a dimension can now display varying numbers of decimal places.
For example, items of a dimension representing international currencies could
display the appropriate number of decimal places for each specific currency.

Viewing Long Labels or Dimension Names

Positioning the pointer over a heading or dimension tile whose name cannot be
fully viewed will reveal its full description or name.

Printing

The former side-by-side nesting format of a printed table has been replaced
with indented nesting to improve readability.
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Insert Bar

The insert bar has been removed and all editing is now done in-place.

Worksheets

The View Worksheet command allows you to create a working copy of all or
part of the current view of a table. This option allows you to manipulate part of
the table, without affecting the original table, by placing the selected data into a
worksheet. Any table operations may be made on the worksheet, such as group
calculations, data imports, saving data to a table, etc. These operations may be
made even if the original table is read-only.

Distributions

This command now creates a separate window.

Saved Views

Normally, any changes you make to the layout of the table view are lost when
you close the table; however, a saved view allows you to keep those changes. A
saved view is a personalized snapshot of a table that allows you to quickly
recall a specific table layout without having to redefine its attributes. You can
save as many views of the table as you wish, and then later display the table
according to a particular saved view.

Complete Language Functionality in Extracts

Full language support is now included in extract files.

Numeric Indicator in Source Field Tiles

A small number sign is now displayed in the lower left corner of the source
field tile to indicate a numeric source field.

Extract File Remains Open after Building a Table

After building a table from an extract, the extract file now remains open. This
allows the user to build additional tables without re-opening the extract file.

Export to SAS and SPSS from Extracts

Extracts may now be exported to SAS and SPSS file formats.

Logging Features

Unrecognized errors will now be sent to a log file (*.log) and will be displayed
to the user to facilitate remote support.



Chapter 1:  Working in the Browser
Window

Overview
This chapter describes the objects you see on the screen and provides step-by-
step procedures which explain how to change the appearance of a document
window.

What is the Browser?
The Beyond 20/20 Browser is a Windows-based program used to browse
Beyond 20/20 tables and extracts.

Browsing is a collective term that is used to describe the dynamic way you look
at and manage the information the Browser presents. Browsing begins the
moment you start the Browser, and it ends as soon as you are satisfied that your
view contains the information you are looking for.

In general, browsing involves:

• Opening one or more tables or extracts.

• Examining their contents.

• Identifying the relevant data.

These activities are carried out from within the Browser window. The Browser
window provides the tools you need to browse tables and extracts and work
with the information in them. It contains features that are common to all
Microsoft Windows applications.

Beyond 20/20 Browser Files
The following information briefly describes the files associated with the
Beyond 20/20 Browser.
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Table File (*.ivt)

This file holds all the data and textual information associated with a table, as
well as information on how the table is displayed.

Extract File (*.ivx)

An extract file is used to create a personalized table. It includes textual
information: the name, type, description, and category of the extract, and the
dimension definition file references for each source field in the extract.

Dimension Definition File (*.ivd)

A dimension definition file defines a dimension of a table or a source field of an
extract. It generally contains information about the dimension (i.e., its name,
description and type), and the codes and labels associated with the items of the
dimension. It can optionally contain notes, a hierarchical structure, language
specific information, or a link to a map file.

When an extract is created, a dimension definition file is generated for each
source field in the extract. In addition to the information described above, a
dimension definition file associated with an extract contains the data associated
with each item in the source field.

Profile File (*.ivp)

This file contains the dimension name and an ordered set of codes associated
with a profile. A profile is a user-defined collection of items. These items can be
selected or shown when the profile is loaded.

Browser Menus
The Browser commands have been logically grouped into menus according to
their purpose. The menu bar is dynamic and reflects the menus that are
appropriate to your current view.

The File, Edit, Window, and Help menus are similar to those in most Windows-
based applications and provide access to basic Windows functions. Additionally,
the File and Edit menus provide you with access to unique Beyond 20/20
features, and the Window menu’s Preferences command allows you customize
the user interface.

The commands in the View menu control what is shown in your current view.
You can create map and chart views using the View menu. The Dimension and
Item menus assist you in performing tasks specific to dimensions and items.

The Data menu concentrates on tasks that affect the output of the table creation
process and contains commands that initiate the table creation process.
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Note:  A shortcut menu is one that is shown when you click the right mouse
button from the active window. The Browser incorporates shortcut menus in the
current view when appropriate, and their contents vary depending on the current
activity.

The Toolbar
The toolbar is comprised of the Active Dimension box, the Previous and Next
Item buttons, and the toolbar buttons.

Active Dimension Box   

The Active Dimension box identifies the dimension that is currently selected. A
dimension must be active if you want to do something with it (e.g., sort, search,
view, or change labels). To set the active dimension, select the desired
dimension from the drop-down list box.

Previous Item and Next Item Buttons     

The arrow buttons on either side of the Active Dimension box are called the
Previous Item and Next Item buttons. They let you step through the items in a
dimension.

Clicking the Previous Item or Next Item button when the column or row
dimension is active moves the cursor along the column or row. When the active
dimension is positioned in the dimension bar, the buttons are used to
sequentially display the data associated with the next item.

Toolbar Buttons

Toolbar buttons provide you with shortcuts to some of the most-often-used
menu commands. A summary of the function of each toolbar button is provided
below:

Button Name Function

Open File Lets you select and open a table or an extract by entering its
location and file name. Clicking the Open File button does
the same thing as choosing Open from the File menu.

Find Opens the Find dialog box which lets you search for,
identify, and open a table or an extract. Clicking the Find
button does the same thing as choosing Find from the File
menu.

Tile
Documents

Arranges all open documents into a tile pattern. Clicking the
Tile Documents button does the same thing as choosing Tile
from the Window menu.
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Button Name Function

Change
Labels

When the active dimension contains two or more fields, the
Change Labels button moves from one field to the next,
displaying the new text for each item as it steps through the
fields. Clicking the Change Labels button does the same
thing as choosing Change Labels from the Dimension menu.

Print View Prints the active view. Clicking the Print View button does
the same thing as choosing Print from the File menu.

Search
Dimension

Lets you enter text or a numeric range that the Browser will
search for in the active dimension. A search can either
expand or reduce the number of items in the view, or it can
find an item. Clicking the Search Dimension button does the
same thing as choosing Search from the Dimension menu.

Sort
Dimension

Sorts the items in the active dimension in ascending or
descending order. Clicking the Sort Dimension button does
the same thing as choosing Sort from the Dimension menu.

Display
Fields

Opens a window on the field information associated with
the active dimension. Clicking the Display Fields button
does the same thing as choosing Dimension from the View
menu.

Display Chart Creates a chart view based on the items you select in a table
view. Clicking the Display Chart button does the same thing
as choosing Chart from the View menu.

Display Map Displays a map view that corresponds to the active table
view. Clicking the Display Map button does the same thing
as choosing Map from the View menu.

Go Performs the Load Data operation to create a table. Clicking
the Go button does the same thing as choosing Go from the
Data menu.

Language Simultaneously changes the language of a multilingual table
and the user interface. Clicking on the Language button does
the same thing as selecting a language in the Preferences
dialog box (Window menu).

Note:  The table must contain descriptive components in
two or more languages.
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The Document Window and Presentation Options

Objects in the Document Window
The Browser window changes, depending on whether you are working with a
table or an extract.

The following Browser window contains the four-dimensional demonstration
table, PRODUCTS. The REGION dimension is along the rows and the TIME
PERIOD dimension is across the columns. The UNITS and the COOKIE TYPE
dimensions are positioned in the dimension bar.

The following Browser window contains the demonstration extract, SURV.
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Each document window has its own Control-menu box, title bar, Minimize and
Maximize buttons, and vertical and horizontal scroll bars, regardless of whether
an extract, a table, a chart, a map or a dimension view is displayed in it.

Row Dimension Area

The row dimension area is the area where source field tiles can be positioned to
create the row dimension.

In an extract, this area is initially blank. To create a table, a source field tile is
dragged into the row dimension area and consequently becomes the row
dimension.

Column Dimension Area

The column dimension area is the area where source field tiles can be
positioned to create the column dimension.

In an extract, this area is initially blank. To create a table, a source field tile is
dragged into the column dimension area and consequently becomes the column
dimension.

Dimension Bar

The dimension bar is where source field tiles can be positioned to create
dimensions other than the column and row dimensions.

In an extract, this area is initially blank. To create a table, a source field tile is
dragged into the dimension bar area and consequently becomes a dimension in
the dimension bar.

Source Field Bar
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The source field bar contains a list of source field tiles from which you can
create a table. It appears, when appropriate, down the right-hand side of the
screen. A small number sign in the lower left corner of the source field tile
indicates a numeric source field. The source field bar can only be seen when an
extract is open.

Status Bar

The status bar provides information about the active view and the current or
selected item(s).

Scroll Bars

Vertical and horizontal scroll bars appear in the document window when
columns and rows in a maximized table view expand beyond the size of the
workspace. Use them to scroll to items you cannot see, or to scroll to any
windows or icons that have been moved outside of the workspace.

Changing the Language of a Table
A multilingual table is one whose descriptive components are available in more
than one language.

When a multilingual table is initially opened, it is displayed in the language of
preference as defined in the Preferences dialog box. The status bar always
indicates the current language of a multilingual table.

The following list defines the language abbreviations used in the status bar:

Abbreviation Language

DAN Danish

DEU German

ENG English

ESN Spanish

FIN Finnish

FRA French

ISL Icelandic

ITA Italian

NLD Dutch

NOR Norwegian

PTG Portuguese

SVE Swedish
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À To view a multilingual table in one of its alternate languages

1. Do one of the following:

• Press F9.

• From the View menu, choose Change Language.

 Note:  Subsequent selections of the Change Language command or
function key display the table in its next available language.

Changing the Table and User Interface Languages
The Language button on the toolbar changes the language of a multilingual
table and the user interface.

Note:  The multilingual table must contain descriptive components in two or
more languages. To view any additional languages, press F9.

À To change the language of a table and the interface simultaneously

1. Click the Language button on the toolbar.

 The descriptive components of the table and the user interface are changed
to the language you selected.

Displaying a Table Title in the Window Header
You have the option of displaying either the one-line table title or the table
name in the title bar of the table view. By default, the one-line title is displayed.

À To display the table name in the table view header

1. From the Window menu, choose Preferences.

 The Preferences dialog box appears.

2. Clear the Display Table Title in Document Window Title Bar check box.

3. Click OK.

 The table name is displayed in the title bar of the table view.

Selecting Colors for a Table View
You can change the color of the dimension tiles and item headings. You can also
select a color to indicate which tile and/or heading is currently active.
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À To select a dimension color and a selection color

1. From the Window menu, choose Preferences.

2. In the Dimension Color box, select a color for all tiles and headings.

3. In the Selection Color box, select a color to represent selected objects.

4. Click OK.

 The table view contains the colors you selected.

Resizing Dimension Tiles and Headings
When a table is initially opened, the width of the row headings are
automatically adjusted to accommodate the longest item. However, when you
change labels or switch dimension tiles, the space provided in a heading may be
too wide or not wide enough to accommodate the text in the heading.

À To alter the width of a heading

1. Click on one of the following: the border of the first heading in the column
dimension, the border of any heading in the row dimension, or the border
of a tile in the dimension bar.

2. Do one of the following:

• To increase the width of the heading, drag the border to the right.

• To decrease the width of the heading, drag the border to the left.

 As you drag the mouse, shadow line(s) indicate how far the border has
moved.

3. Release the mouse button.

 The width of the headings are altered.

Tiling and Cascading Document Windows
The Browser can display document windows side-by-side in a tile arrangement,
or one behind the other in a cascade arrangement. Arranging the windows this
way lets you see how many windows are open and provides immediate access
to all of the windows. To access a document window, click on it to make it
active.

À To tile all document windows

1. Do one of the following:

• Click the Tile Documents button on the toolbar.
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• From the Window menu, choose Tile.

 The Browser arranges all of the document windows side-by-side.

 Tip:   You can automatically tile all chart and map windows. From the
Window menu, choose Preferences and select the Automatically Tile
Windows on Creation check box.

À To cascade all document windows

1. From the Window menu, choose Cascade.

 The Browser arranges all of the document windows one behind the other,
leaving the title bar of each showing.

Closing Document Windows
You can close a window by double-clicking on the window’s Control-menu box.
However, the effects will differ, depending on whether the window contains a
table view, a dimension view, a chart view, or a map view.

To close all files and document windows associated with them, from the
Window menu, choose Close All.

To close all document windows associated with a table, including map and chart
windows, double-click on the Control-menu box of a table window, or from the
File menu, choose Close.

To close only a dimension view, chart view, or map view, double-click on the
Control-menu box of that window.



Chapter 2:  A Quick Tour of the
Browser

Overview and Prerequisites
In this section we will explore the step-by-step procedures used to browse a
table and to create a simple table from an extract. This guided tour is in four
parts:

Part 1 Starting a Browser Session

Part 2 Working With Tables

Part 3 Working With Extracts

Part 4 Ending a Browser Session

Before you begin you need to know where the Beyond 20/20 sample files are
located on your system. If necessary, check with your system installer.

Part 1 - Starting a Browser Session
When the Beyond 20/20 software was installed on your workstation, a program
group containing the Beyond 20/20 Browser application was created in the
Microsoft Windows Program Manager window.

À To start the Beyond 20/20 Browser

1. Start Microsoft Windows.

2. Open the Beyond 20/20 program group.

3. Double-click on the Beyond 20/20 Browser icon.

 The interface is loaded and the Find dialog box appears.
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Part 2 - Working With Tables

Finding and Opening a Table
When you first start the Browser, the Find dialog box is automatically displayed
to provide you with the easiest and quickest way to find and open a table or an
extract.

Note:  You can control whether the Find dialog box automatically appears when
you open the Browser. To suppress the display of the Find dialog box, from the
Window menu, choose Preferences, and clear the Display the Find dialog box
on Start Up check box.

À To open a table

1. In the Category box, confirm that the ‘Beyond 20/20 Demonstration Tables
and Extract’ category is selected.

 Two table names and one extract name are displayed in the Name/Type
box. They are assigned to the Beyond 20/20 Demonstration Tables and
Extract category.

2. In the Name/Type box, select ‘PRODUCTS.’ The full table title is
displayed in the Title area.

3. Click Summary for an extended description of the table.

4. Click Cancel to return to the Find dialog box.
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5. Do one of the following:

• Double-click on ‘PRODUCTS.’

• Click OK.

 The PRODUCTS table appears. The window fills the workspace; the title
of the table is added to the information in the window title bar.

Browsing the Table

Browsing Through Items

The Next Item and Previous Item buttons on the toolbar can be used to
sequentially display the items in the active dimension. If the column dimension
or row dimension is active, the cursor simply moves along a column or row.
However, if a dimension in the dimension bar is active, the Browser displays
the data associated with the next or previous item in that dimension.

À To browse through items

1. Do one of the following:

• Click on the COOKIE TYPE dimension tile.

• In the Active Dimension box, select COOKIE TYPE.

2. Click the Next Item button on the toolbar.

 The view changes to show the data associated with the next item, ‘Ginger
Zings.’

3. Continue clicking the Next Item button.

 There are six items in the COOKIE TYPE dimension. Each time you click
the Next Item button, a new view for a single item is displayed.

Opening a Dimension View

Dimensions comprise a number of fields: the code field, data field, and
optionally, one or more label fields. If you are not familiar with the fields that
make up a dimension, open a view of the dimension to determine its contents.

When you open a dimension view, the Browser displays the code field and the
label fields associated with that dimension’s items. Data cannot be seen in a
dimension view; they can only be displayed in a table view.

À To open a dimension view

1. Click on the COOKIE TYPE dimension.
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2. Do one of the following:

• Click the Display Fields button on the toolbar.

• From the View menu, choose Dimension.

 The COOKIE TYPE dimension view appears.

 

3. Double-click on the Control-menu box of the dimension view to close the
dimension view.

 Tip:   You can search a dimension’s fields from inside a table view. For
more information about searching fields, refer to “Searching Items” on
page 50.

Changing the Labels of Dimension Tiles and Headings

The symbols and/or text that make up a dimension’s codes and labels can be
displayed (one field at a time) in a dimension tile, or in the headings associated
with the column and row dimensions. As long as the display of a label field has
not been suppressed by the Builder, you can choose which field the Browser
displays in the table view.

À To change labels

1.  Click on the REGION dimension.

2.  Do one of the following:

• Click the Change Labels button on the toolbar.

• From the Dimension menu, choose Change Labels.

 The Browser displays the next available label field for the REGION
dimension.
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 When the active dimension contains two or more fields, subsequent
selections of the Change Labels command or toolbar button displays the
next label field.

 Tip:  Sometimes the space in a heading is not wide enough to
accommodate the entire length of a code or label. To change the width of a
heading, refer to “Resizing Dimension Tiles and Headings” on page 15.

Switching Dimensions

You can have two dimensions change places in the table view. You do this by
dragging and dropping one dimension tile on top of another dimension tile.

À To switch two dimensions

1. Click on the COOKIE TYPE dimension tile and hold down the left mouse
button.

2. Drag and drop the tile on top of the TIME PERIOD dimension tile, or over
any of the headings in the column dimension.

 The first item in the TIME PERIOD dimension, Jan1991, is displayed in
the dimension bar. All of the items in the COOKIE TYPE dimension are
displayed in the column dimension.

 Tip:  You can switch any single item from the column or row dimension
into the dimension bar by dragging and dropping its heading into the
dimension bar. For more information, refer to “Switching Dimensions” on
page 43.

Nesting Dimensions

You can display more than one dimension along the columns or rows. You do
this by dragging and dropping a dimension tile into the column or row
dimension area.
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À To nest a dimension

1. Click on the TIME PERIOD dimension tile and hold down the left mouse
button.

2. Drag the tile over the upper border of the headings in the column
dimension.

 The upper border of the column dimension area is highlighted.

3. Drop the dimension tile.

 A new set of headings is created in the table view where you dropped the
tile.

Searching Items

In a typical scenario, you may want to look at a specific aspect of data. To do
this, you can use the Search command.

In this exercise, you will use the Search command to determine which regions
enjoy the greatest volume of cookie sales.

Position the TIME PERIOD dimension in the column dimension area, and the
REGION dimension in the row dimension area. Nest the COOKIE TYPE
dimension below the TIME PERIOD dimension. Select the Revenues($000)
item in the UNITS dimension located in the dimension bar.
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To compare the regions that have the highest volumes of sales, specify a
minimum revenue figure, and direct the Browser to reduce the display of items
to show items that are higher than the specified minimum.

À To search items

1. Click on the REGION dimension tile.

2. Click on a cell in the All Cookie Types column.

3. Do one of the following:

• Click the Search Dimension button on the toolbar.

• From the Dimension menu, choose Search.

 The Search dialog box appears.

 

4. In the Field box, confirm that ‘Data’ is selected.

5. In the Type of Selection area, confirm that the Reduce option button is
selected.

6. In the Minimum box, enter ‘700.’

7. Click OK.



24    Beyond 20/20 Browser User’s Guide

 

 The revenues that are lower than the specified minimum are hidden. The
status bar reads that 7 out of 15 items in the REGION dimension are
displayed.

 Tip:   You can search the code field or any of the available label fields. The
Browser can decrease or increase the number of items on display, or it can
find and display the item you specify. For more information about
searching, refer to “Searching Items” on page 50.

Sorting Items

You can sort items according to the value of their data.

In this exercise, you will sort the items in the TIME PERIOD dimension to see
which months are associated with the highest sales revenue.

À To sort items

1. Click on the TIME PERIOD dimension tile.

2. Do one of the following:

• Click the Sort Dimension button on the toolbar.

• From the Dimension menu, choose Sort.

 The Sort dialog box appears.
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3. In the Field box, select ‘Data.’

4. In the Sort Options box, select ‘Decreasing.’

5. Click OK.

 The Browser sorts the items in the TIME PERIOD dimension in decreasing
order. The cursor remains fixed on the item it was on prior to the sort.

 The greatest single revenue associated with the All Cookie Types item is
displayed in the left-most column, and the remaining data values are sorted
in decreasing order as you scroll right. If you scroll to the right, past the
first items in the TIME PERIOD dimension, you will see that the three best
months are Mar1994, Dec1993 and Nov1993. As you scroll, the position
indicator in the window displays the codes of the items in the TIME
PERIOD dimension as you scroll past them.

Changing Group Levels

The items in the REGION dimension are assigned to groups. You can inspect
groups one level at a time.

À To change group levels

1. Click on the REGION dimension tile.

 The status bar displays the letter ‘T’ to indicate that the active cell North
America comprises a group of items.

2. From the Dimension menu, choose Zoom In.

 As you change group levels, the headings in the active dimension change.
The three items Canada, United States, and Mexico are displayed.

 The ‘T’ in the status bar indicates that the active cell, Canada, defines a
group and the ‘M’ indicates that it is also a member of a group.

3. From the Dimension menu, choose Zoom In.
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 There are four items in the Canada group: Maritimes, Quebec, Ontario, and
Western Canada. The ‘M’ in the status bar indicates that each of these items
is a member of the group Canada.

Hiding Items

There are two quick ways to hide items. You can hide an item explicitly or
implicitly. To hide an item explicitly, select its heading and from the Item
menu, choose Hide.

À To hide items implicitly

1. Drag the COOKIE TYPE dimension into the dimension bar.

2. Drag the pointer across the first three headings in the column dimension,
Mar1994, Dec1993, and Nov1993.

3. Do one of the following

• Click the right mouse button. Choose Show.

• From the Item menu, choose Show.

 The items you selected remain on display and the items you did not
select are hidden.

Displaying a Chart
You can chart the items you select in the table view and change the default
chart type to a pie, a line, or a scatter plot chart, among others. The Browser
also provides options for styling the elements in the chart view.

You can display a new view for a single item, step through the codes and labels,
open a dimension view, change group levels, or search the items.

In addition, you can replace the items in the horizontal axis and in the legend
after a chart view has been created. This feature allows you to add more items
from the same dimension, or switch the dimension currently on display. The
Browser updates the corresponding labels automatically. For more information
on charts, refer to Chapter 6, “Charts,” on page 71.



Chapter 2:  A Quick Tour of the Browser    27

À To display a chart view

1. In the column dimension of the table view, select the three items: Mar1994,
Dec1993, and Nov1993.

2. Do one of the following:

• Click on the Display Chart button on the toolbar.

• From the View menu, choose Chart.

 A chart view appears.

3. Double-click on the Control-menu box to close the chart view.

Displaying a Map
If a table has geographical information associated with it, you can view the
table data in a map.

You can select the colors that are used to identify which regions and cities have
the highest, middle, and/or lowest data values on record. You can also select
whether labels and/or data values are displayed in a map view. The Browser can
display maps with or without numbers, region names and/or cities.

When you select a title caption, the associated dimension is made active. You
can then look at one item at a time by choosing the Next Item and Previous
Item buttons on the toolbar. As you browse through items in the map view, the
regions labels change to reflect the new information, or a new region is
displayed. You can zoom in or out of a region, or you can search the codes or
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labels. For more information about maps, refer to Chapter 7, “Maps,” on page
85.

À To display a map view

1. Do one of the following:

• Click the Display Map button on the toolbar.

• From the View menu, choose Map.

 A map view appears.

2. Double-click on the Control-menu box to close the map view.

Part 3 - Working With Extracts
You can create a Beyond 20/20 table from an extract file. In this exercise you
will create a table from the sample extract SURV.IVX.

Finding and Opening an Extract

À To open an extract

1. Do one of the following:

• Click the Find button on the toolbar.

• From the File menu, choose Find.
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2. The Find dialog box appears.

 

3. In the Categories box, confirm that the ‘Beyond 20/20 Demonstration
Tables and Extract’ category is selected.

 The sample extract and two table names are displayed in the Name/Type
box. They are assigned to the Beyond 20/20 Demonstration Tables and
Extract category.

4. In the Name/Type box, select ‘SURV.’ The full extract title is displayed in
the Title area.

5. Click Summary for an extended description of the extract.

6. Click Cancel to return to the Find dialog box.

7. Do one of the following:

• Double-click on ‘SURV.’

• Click OK.

 The Browser displays an empty table view containing SURV.IVX.

 For more information about opening an extract, refer to “Opening Tables
and Extracts” on page 37.

Positioning Table Dimensions
To create a multi-dimensional table, you must define what the dimensions of
the table will be and where they will be positioned. You position dimensions by
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dragging and dropping source field tiles into the row, column, and dimension
bar areas of the table view.

À To position dimensions

1. Click on the Region source field tile and hold down the left mouse button.

2. Drag the tile into the row dimension area.

3. Release the mouse button.

 The dimension tile appears in the table view and the Region tile is dimmed
in the source field bar.

 Similarly, use the following information to position the remaining source
field tiles into their corresponding dimension areas:

Source field tile Dimension area

RateZings Column dimension area

Criteria Dimension bar

AmountWeekly Dimension bar

 You have just defined a four-dimensional table. For more information about
positioning source field tiles, refer to “Positioning Tiles for Dimensions” on
page 108.

Loading Data into the New Table
Once you have defined a table by dragging a minimum of two source field tiles
into the dimension areas, you can load the data into the table.

À To load data into the table

1. Do one of the following:

• Click the Go button on the toolbar.

• From the Data menu, choose Go.

For more information about extracts, refer to Chapter 8, “Extracts,” on page 97.

Naming and Saving the Table

À To name and save the table

1. From the File menu, choose Save As.

 The Save As dialog box appears.
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2. In the File Name box, enter ‘SAMPLE.IVT.’

3. Click OK.

Documenting the Table
The Summary dialog box can be accessed at any time by choosing the File
command from the Summary cascade menu in the Edit menu. A table summary
contains general information about the table and assists Browser users in
understanding the contents of the table.

Here is a sample of a table summary.

À To document the table

1. Using the sample table summary as a guide, enter the following
information:

Box Summary Information

Title A description of the table.

Category A subject area classification for the table.

Author The author of the table.

Keywords Words a Browser user can enter to search for the table.

Notes Any notes you wish to associate with the table that may be
helpful to Browser users.

Summary

 You have just created and documented a four-dimensional table called
SAMPLE.
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Part 4 - Ending a Browser Session
You can quit a Browser session at any time.

À To quit the Beyond 20/20 Browser

1. Close any open dialog boxes.

2. From the File menu, choose Exit.

The Browser user interface is unloaded.



Chapter 3:  Finding and Opening
Tables and Extracts

Overview
Tables and extracts can be located through the Find or the Open dialog box. The
Find dialog box assists you in finding the table or extract you want to open by
allowing you to select categories, search fields, and view summaries. The Open
dialog box directly opens a table or an extract.

Finding a Table or an Extract by Category
You can search for tables and extracts by category using the Find dialog box.
By default, the Find dialog box is displayed automatically when a Browser
session begins. The Find dialog box may also be manually opened at any time
during a Browser session.

Note:  To suppress the display of the Find dialog box on start up, from the
Window menu, choose Preferences, and clear the Display the Find dialog box
on Start Up check box.

À To open the Find dialog box manually

1. Do one of the following:

• Click the Find button on the toolbar.

• From the File menu, choose Find.

 The Find dialog box appears.
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 With the Find dialog box open, you can:

• Change directories to see tables and extracts that are stored elsewhere.

• Select one or more categories to create a list of the tables and extracts
assigned to those categories.

• Search for tables and extracts according to the criteria you specify.

• View a table or an extract summary.

• Open a table or an extract directly from those presented.

Changing Directories
In some cases, not all tables and extracts are stored in one directory. If you do
not see the table or extract you want to open, you can manually enter the correct
directory, or use the Browse button to change directories.

À To change directories

1. From the Find dialog box, click the  (Browse) button.

 The Directory dialog box appears.

2. In the Drives box, select the drive where directory is located.

3. In the Directories box, select the directory (and subdirectories) where the
table or extract is stored.

4. Click OK to return to the Find dialog box.
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Selecting Categories to Find Tables or Extracts
When tables and extracts are prepared, part of the procedure is to assign a
category name to each table and extract. The Categories box displays all of the
category names that are assigned to the tables and extracts in the current
directory.

When you open the Find dialog box, the first category displayed is
automatically selected. The Name/Type box provides you with a list of all of
the tables and extracts assigned to that category. This list contains table and
extract names, their titles, and indicates whether the file is a table or an extract.

À To select one or more categories

1. In the Categories box, select the category name that interests you.

2. To select more than one category, do one of the following:

• Click on and hold the left mouse button while dragging the pointer
along the category names.

• Hold the Ctrl key down and click on the category names.

 Each time you add a new category to those selected, the Browser adds the
associated tables and extracts to the Name/Type box.

À To see a list of all the tables and extracts in the current directory

1. From the Find dialog box, click All.

 All of the table and extract categories are selected. Consequently, all of the
tables and extracts in the current directory are displayed in the Name/Type
box.

 Tip:  To clear the selection of all categories, click None.

Next Steps:

To search for a specific table or extract, proceed to “Searching for Relevant
Tables and Extracts” on page 35.

To open a specific table or extract, double-click on its name in the Name/Type
box.

Searching for Relevant Tables and Extracts
Beyond 20/20 tables and extracts have descriptive components which tell you
something about the contents. These descriptive components can be searched to
help you locate the table or extract you are looking for.



36    Beyond 20/20 Browser User’s Guide

À To search the descriptive components of a table or an extract

1. From the Find dialog box, click Search.

 The Search Components dialog box appears.

 

2.  In the Text to Find box, enter the symbols or text you want to search for.

 Note:  The Browser compares the symbols or text you specify to the text
stored in the table or extract’s descriptive components.

3.  In the Search Options area, select the options you want to search.

Component What kind of text it contains

Title/Description A brief description of the table or extract.

Notes An extended description of the table or extract.

Keywords A list of individual words or phrases that are
associated with the table or extract.

Dimension/Source Field
Names

The names assigned to the dimensions of a table or
the source fields of an extract.

Codes A code is a symbolic value that uniquely identifies
an item. A code can be an abbreviation, or a
combination of numbers and letters.

Labels A label is an optional word or phrase that
describes an item, or the code which identifies that
item. It can be the name of a person, place, object,
or time value.

4. Click OK.

 The Browser searches the tables and extracts currently listed in the
Name/Type box.

 If a match is found, the table and/or extract name is displayed in the
Name/Type box. In addition, a message showing the total number of tables
and/or extracts found is displayed above it.
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 If a match is not found, the Name/Type box is empty and the message “0
found” is displayed above it. In this case, you may want to clear the search
result and try a different search.

À To clear the results of all searches

1. From the Find dialog box, click Clear.

 The Find dialog box is reset.

Next Steps:

To view an extended description of a table or extract, proceed to “Viewing a
Summary” on page 37.

To open a specific table or extract, double-click on its name in the Name/Type
box.

Viewing a Summary
A table or an extract summary contains information which may help you locate
a particular table or extract.

À To view a summary from the Find dialog box

1. Select the table or extract that contains the extended description you want
to view.

2. Click Summary.

 The Summary dialog box appears displaying the table or extract summary.

3. Click Cancel to return to the Find dialog box.

Next Steps:

To open a specific table or extract, double-click on its name in the Name/Type
box.

Opening Tables and Extracts
You can open tables and extracts through the Find dialog box or the Open
dialog box.

À To open a table or an extract from the Find dialog box

1. Do one of the following in the Find dialog box:

• Double-click on the table or extract name.
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• Select the table or extract name. Click OK.

À To open a table or an extract from the Open dialog box

1.  Do one of the following:

• Click the Open File button on the toolbar.

• From the File menu, choose Open.

 The Open dialog box appears.

 

2.  Select the table or extract you want to open.

 If you do not see the file you want to open, select a different drive,
directory or file type to locate the file.

3.  Click OK.

A table or extract is displayed in a new document window.



Chapter 4:  Browser Basics

Overview
This chapter provides step-by-step procedures on how to:

• Use fundamental browsing techniques such as selecting, hiding, showing,
nesting, and switching.

• Use features directly related to items and dimensions.

• View table descriptions.

Browsing Fundamentals

Browsing Items
When a dimension is displayed in the dimension bar, the Next Item and
Previous Item buttons are used to sequentially display its items. When you
choose either of these buttons, the column and row data are updated each time
you move to a new item.

À To browse through the items associated with a dimension

1. Select the dimension you want to browse.

2. Do one of the following:

• Click the Next Item button on the toolbar to see the next item in the
dimension.

• Click the Previous Item button on the toolbar to see the previous item
in the dimension.

 Your view of the data changes to show the data associated with the next or
previous item in the active dimension.

3. Continue clicking on the Next Item or Previous Item button until you see
the item you want.
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 Tip:   If you are working with a large table, the fastest way to display a
different item may be to search that dimension. For information about
searching items in a table, refer to “Searching Items” on page 50.

Selecting Objects
Selecting an object indicates which part of the table you want to work with.
(Selecting an object makes it active.) For example, if you want to reposition a
dimension, copy an item to another application, or sort the items in a
dimension, you must first select the related object. In general, click on an object
to select it.

À To select a dimension tile

1. Do one of the following:

• Click on the dimension tile you want to use.

• Click on the Active Dimension box. Select the name of the dimension
you want to use.

 Notes:  When you select a dimension in the dimension bar, the dimension
and the single item on display are both selected.

 The dimension tile is selected and highlighted in the selection color. The
corresponding dimension is now ‘active’ and its name appears in the Active
Dimension box.

À To select a dimension tile using the keyboard

 Note:  To force the Browser to release control of the keyboard at any time
during the following procedure, press Esc.

1. Press Alt, V.

 The View menu drops down.

2. Do one of the following:

• Using the down arrow key, move the cursor to the Set Active
Dimension command. Press Enter.

• Press A.

 The Set Active Dimension dialog box appears.

3. Do one of the following:

• Using the up or down arrow keys, move the cursor to the name of the
dimension you want to make active.
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• Enter the first letter of the dimension name that you want to make
active.

4. Press Enter.

 The dimension tile is selected and highlighted in the selection color. The
corresponding dimension is now ‘active’ and its name appears in the Active
Dimension box.

À To select a single heading

1. Click on the row or column item heading you want to use.

 The item heading, all of its associated data, and the corresponding
dimension tile are highlighted.

À To select multiple adjacent headings

1. Position the cursor over the heading of the first item you want to use. Click
on and hold the left mouse button.

2. Drag the pointer along the headings of the items you want to use.

3. Release the left mouse button.

 The item headings, all of their associated data, and the corresponding
dimension tile are highlighted.

À To select multiple non-adjacent headings

 Note:  This technique lets you select headings from the same dimension, as
well as headings from other dimensions.

1. Click on the heading of the first item you want to use.

2. Hold the Ctrl key down and click on the heading of the next item.

3. Repeat Step 2 until the headings of all of the items you want to select are
highlighted.

 The item headings and all of their associated data are highlighted. The
Active Dimension box displays the dimension name of the item selected
last.

À To select all of the item headings in a dimension

1. Select the dimension you want to use.

2. From the Item menu, choose Select All.
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À To select a cell

1. Click on the cell you want to use.

 A box appears around the selected cell. This is called the cursor.

 Tip:   The arrow keys can be used to move the cursor from one cell to the
next in the same column or row. Alternatively, you can click the Next Item
or Previous Item buttons on the toolbar to move the cursor from one cell to
the next (one at a time) along a column or row.

Hiding and Showing Items
When a table is initially opened all items are shown. Depending on the number
of items in these dimensions, your view could be quite large. You can make the
view more manageable by hiding the items you do not need.

Notes:  Hiding items does not delete them. You can return items to the view at
any time.

You can use the Search command as an alternate way to hide items. When an
item does not match the search criteria you specify, it is hidden from the table
view. For more information, refer to “Searching Items” on page 50.

À To hide selected items from a table view

1. Select the headings of the items you want to hide.

2. Do one of the following:

• Click the right mouse button. Choose Hide.

• From the Item menu, choose Hide.

 The items you selected disappear from the view.

 Note:  To return the hidden items to the table view, select the dimension
and from the Dimension menu, choose Reset.

À To show only the items you select

1. Select the heading(s) of the items you want to display.

2. Do one of the following:

• Click the right mouse button. Choose Show.

• From the Item menu, choose Show.

 The items you did not select disappear from the view.
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À To display the reverse set of items on display

1. Select the dimension that contains the hidden items you want to see.

2. From the Dimension menu, choose Reverse.

 All of the items in the view are replaced by the ones that were hidden.

À To show all of the items in a dimension

1. Select the dimension that contains the hidden items you want to see.

2. Do one of the following.

• Click the right mouse button. Choose Show All.

• From the Dimension menu, choose Show All.

 All of the active dimension’s items are displayed in the table view.

Switching Dimensions
Switching dimensions involves dragging a dimension tile from the dimension
bar into the table, or dragging a heading from the column or row dimension
areas into the dimension bar. When the tile or heading is dropped, the two
dimensions change places. Column and row dimensions can be also be
interchanged.

À To switch dimensions

1. Select the dimension you want to move.

2. Do one of the following:

• Drag and drop the tile on the row headings if you want to replace the
row dimension.

• Drag and drop the tile on the column headings if you want to replace
the column dimension.

• Drag and drop the tile on a dimension in the dimension bar if you want
to replace one of the dimensions in the dimension bar.

Nesting Dimensions
Nesting lets you display more than one dimension along the columns or rows. It
involves positioning a dimension tile over the border of existing headings in the
column or row dimension. When the tile is released, new headings are added to
the column or row areas.
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In the following figure, the OCCUPATION dimension is nested along the rows.

À To nest dimensions

1.  Select the dimension, in the dimension bar, you want to nest.

2.  Do one of the following:

• Drag and drop the dimension tile onto the outer or inner border of the
row headings to nest along the rows.

• Drag and drop the dimension tile onto the top or bottom of the border
of the column headings to nest along the columns.

 The border of the row or column headings becomes highlighted when the
dimension tile is ready to be dropped.

Switching and Nesting Dimensions Using the Keyboard
The Move Dimensions command provides a keyboard alternative for moving a
dimension tile.

À To move a dimension tile using the keyboard

 Note:  To force the Browser to release control of the keyboard at any time
during the following procedure, press Esc.

1. Select the tile you want to move.

2. Press Alt, V.

 The View menu drops down.
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3. Do one of the following:

• Using the down arrow key, move the cursor to the Move Dimensions
command. Press Enter.

• Press V.

4. Press the Tab key repeatedly until the area you want to move the tile to is
highlighted.

 The Browser may highlight another tile or one of the heading areas (to
switch), a border of the heading area (to nest), or the border of a tile in the
dimension bar (to rearrange the order of the tiles in the dimension bar).

5. Press Enter.

 The Browser switches or nests the dimension you selected into the area that
was highlighted.

Working With Items and Dimensions
Before using any of the techniques described below, you must select the
dimension you want to use, thereby making it active. To select a dimension,
either click on the dimension tile, or click on the Active Dimension box and
select the dimension name.

Displaying a Dimension View
If you are not familiar with the fields that comprise a dimension, you can open
a view on the dimension to determine its contents. When you open a dimension
view, the Browser displays the code field and any label fields associated with
that dimension. Data is not available in a dimension view.

À To open a dimension view

1. Select the dimension whose dimension view you want to display.

2. Do one of the following:

• Click the Display Fields button on the toolbar.

• From the View menu, choose Dimension.

 The dimension view appears.
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Displaying Alternate Labels
The fields that make up a dimension of a table are created when the table is
prepared. The Browser derives the codes or labels you see in the dimension tiles
and item headings from this field information.

A dimension always contains one field of codes, and may contain one or more
fields of labels. Each code uniquely identifies an item. Labels help to define the
code, or they can provide additional information about the item itself.

If at least one label field is available for the active dimension, you can display
the code field or the label field(s) in the table view.

À To step through available code and label fields

1. Select a dimension.

2. Do one of the following:

• Click the Change Labels button on the toolbar.

• From the Dimension menu, choose Change Labels.

 The displayed codes or labels are replaced with the next available field of
codes or labels.

 As you continue changing labels, the Browser steps through all of the
available fields one at a time.

Examining Group Levels
A group is an item that has an underlying hierarchical structure assigned to it.
When a dimension contains groups, you can zoom in and out to explore this
hierarchical structure.

To learn how to define a group, proceed to “Groups” on page 121.

Example:  The PEOPLE demonstration table has three levels built into the
OCCUPATION dimension. The All Occupations item defines the highest level
of the group. It comprises a group of three items: Marketing, Production, and
Distribution. The following figure shows the members of the All Occupations
group.
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The items Marketing, Production, and Distribution are also groups made up of
the occupations associated with those departments. The items contained in the
Marketing group are shown in the following figure.

À To display the members of a group

1. In the column or row dimension area, select the item that defines the group
you want to display.

 Note:  To determine whether an item is a group, select the item and check
the status bar. If it contains the letter T, P, or C, the item defines a group.
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2. From the Dimension menu, choose Zoom In.

 The items assigned to the active item are displayed.

À To display the item that defines a group

1. In the column or row dimension area, select any item that is a member of a
group.

 Note:  To determine whether an item is a member of a group, select the
item and check the status bar. If it contains the letter M, the item is a
member of a group.

2. From the Dimension menu, choose Zoom Out.

 The Browser displays the item that defines the group along with any other
items that are on the same level of the hierarchy as the group.

 Note:  To view all of the items of a dimension, from the Dimension menu,
choose Show All.

Dimension Profiles
Dimension profiles are user-defined collections of dimension items. If you work
with certain items frequently, you can save these items as a profile and give the
profile a name and description. You can also create a profile by importing a list
of codes from an ASCII file. Later, you can load the profile and either select or
show only those items belonging to the profile.

À To create a dimension profile

1. Select the items you want to use to create the dimension profile.

2. From the Dimension menu, choose Save Profile.

 The Save Dimension Profile dialog box appears.

 

3. In the Profile Name box, enter a name for the dimension profile.

4. In the Description box, enter a description for the dimension profile.

5. Click OK.

 The items you selected are saved as a dimension profile (*.ivp).
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Next Steps:

To select or show only the items belonging to the dimension profile, proceed to
“To load a dimension profile” on page 49.

À To import a dimension profile

1. From the File menu, choose Utilities, Import Profile.

 The Import Dimension Profile dialog box appears.

 

2. Do one of the following:

• In the Import Filename box, enter the name of the ASCII file you wish
to import.

• Click Browse to locate and select the ASCII file for import.

3. In the Dimension box, enter the name of the dimension you want to
associate the profile with.

4. In the Profile Name box, enter the name you want to give the profile.

5. In the Description box, enter a description of the profile.

6. Click OK.

The profile is now associated with the dimension, and will appear in the
Load Profile dialog box.

Next Steps:

To select or show only the items belonging to the dimension profile, proceed to
“To load a dimension profile” on page 49.

À To load a dimension profile

1. From the Dimension menu, choose Load Profile.

 The Load Profile dialog box appears.
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2. In the Profile Name/Description box, select the profile you want to use.

3. Do one of the following:

• Click Select to select the items belonging to the profile group.

• Click Show to display only those items belonging to the profile group.

À To delete a dimension profile

 Note: Deleting a profile does not delete the items in a dimension.

1. From the Dimension menu, choose Load Profile.

 The Load Profile dialog box appears.

2. In the Profile Name/Description box, select the profile you want to delete.

• Click Delete Profile to delete the dimension profile.

 You are prompted to confirm the deletion.

3. Click Yes.

 To delete another profile, repeat from Step 2.

4. Click Cancel.

Searching Items
The Browser’s dimension search capability allows you to display only the items
you need. This feature allows you to:

• Reduce the number of items in a view.

• Expand the number of items in a view.

• Move the cursor to the item you specify.

To use the search feature efficiently, it helps to be familiar with the fields of a
dimension. (The Search command requires that you specify the name of the
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field you want to search.) You can open a dimension view to look at the fields
of a dimension. To learn how to open a dimension view, refer to “Displaying a
Dimension View” on page 45.

Searching the Code Field or a Label Field

This type of searching should be performed when you know a word or phrase
that describes the items you are looking for.

À To search the code field or a label field

1.  Select the dimension you want to search.

2.  Do one of the following:

• Click the Search Dimension button on the toolbar.

• From the Dimension menu, choose Search.

 The Search dialog box appears.

 

3.  In the Field box, select Code, or the name of a label field.

4.  In the Text to Find box, enter the code, word, phrase, or abbreviation you
want to search for.

 Tip:  The Browser will find this text or code whether it is at the beginning,
in the middle, or at the end of a series of characters. Bearing this in mind,
try to be as specific as possible.

5.  In the Type of Selection area:

Select To

Reduce hide all items that do not match. Previously hidden items
remain hidden.

Expand display all hidden items that match. Previously displayed
items remain displayed.
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Select To

Find Next search through the displayed items and move the cursor to
the first item that matches the search. Hidden items are
ignored, even if they match.

6. Click OK.

The Browser determines whether the field you selected contains the text
you specified and displays the results as specified by your type of selection.

Searching Data

Before you can search data, you must move the cursor to one of the items in the
column or row dimension, whichever is currently inactive. The position of the
cursor defines which item in the inactive dimension will be searched.

Example:  In the figure below, the REGION dimension is active. The position
of the cursor focuses the search on the data associated with all of the items in
the REGION dimension, but only Feb1991 of the TIME PERIOD dimension. In
this example, a search on the regions is restricted to the employee count records
taken in February 1991 for all occupations.

Note:  In the case of nested dimensions, the position of the cursor still focuses
the search on a single item.

À To search the data

 Note:  The data associated with a dimension can only be searched in a table
view. (In a dimension view, only code and label fields are available.)
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1. Select the dimension you want to search.

2. Do one of the following:

• Click the Search Dimension button on the toolbar.

• From the Dimension menu, choose Search.

 The Search dialog box appears.

 

3. In the Field box, select Data.

4. In the Type of Selection box:

Select To

Reduce hide all items that do not match. Previously hidden items
remain hidden.

Expand display all hidden items that match. Previously displayed
items remain displayed.

Find Next search through the displayed items and move the cursor to the
first item that matches the search. Hidden items are ignored,
even if they match.

5. Do one of the following:

• In the Minimum box, enter a number to represent the lowest
(minimum) data value to be included in the search result.

• In the Maximum box, enter a number to represent the highest
(maximum) data value to be included in the search result.

 Tip:  To limit the search result even further, specify both a minimum and
maximum value.

6. Click OK.

 The Browser determines whether any data in the table meets your criteria
and displays the results according to your specifications.
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Searching the Time Series Dimension

A time series search displays only those items that were recorded during a
specific time span. The time span is specified in the Search dialog box.

À To search the time series dimension

1.  Select the time series dimension.

2.  Do one of the following:

• Click the Search Dimension button on the toolbar.

• From the Dimension menu, choose Search.

 The Search dialog box appears.

 

3.  In the Field box, select Timeseries.

4.  In the From area, enter the starting year and month that you want to search
from.

 Note:  In the From and To areas, a month must be indicated by the number
that refers to its chronological order in the calendar year.

5.  In the To area, enter the ending year and month that you want to search to.

6.  In the Type of Selection area:

Select To

Reduce hide all items that do not match. Previously hidden items
remain hidden.

Expand display all hidden items that match. Previously displayed
items remain displayed.

Find Next search through the displayed items and move the cursor to
the first item that matches the search. Hidden items are
ignored, even if they match.
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7. Click OK.

 The Browser determines whether the time series field contains the time
span you specified and displays the results according to your type of
selection.

 Note:  Searching time series data searches the base frequency of the data
regardless of the time series aggregation displayed.

Sorting and Rearranging Items
A table can be sorted numerically by its data or alphabetically by its codes or
labels. The items in a dimension can also be manually rearranged.

À To sort items

 Notes:  If you want to sort by data value, you must be in a table view.

 If you want to sort a particular set of labels, ensure that they are displayed
in the table view.

1. Select the dimension you want to sort.

2. If you are sorting items that are displayed along the rows or columns of a
table, select a cell that lies in the row or column that you want to sort.

3. Do one of the following:

• Click the Sort button on the toolbar.

• From the Dimension menu, choose Sort.

 The Sort dialog box appears. The Field box displays the fields of the
dimension.

 

4. In the Field box, select the field you want to sort.

 The Sort Options box displays the options for the selected field.
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5. In the Sort Options box:

Select If you want to sort using

Increasing data by ascending value.

Decreasing data by descending value.

Increasing Alphabetic the sort key 0-9, A-Z, a-z.

Decreasing Alphabetic the sort key z-a, Z-A, 9-0.

Increasing Numeric the sort key 0-9. All alphabetic codes or labels
will be presented first.

Decreasing Numeric the sort key 9-0. All alphabetic codes or labels
will be presented last.

6. Click OK.

 The items in the current view are displayed in the order specified.

 Note:  To undo the most recent sort, from the Dimension menu, choose
Reset.

À To change the order of items

1. Select the dimension containing the items you want to re-order.

2. Do one of the following:

• Click the Display Fields button on the toolbar.

• From the View menu, choose Dimension.

 The dimension view appears.

3. Hold the Shift key down and click on the index number of the item you
want to move.

4. Drag and drop the item to a new location.

 The item is displayed in its new position.

 Note:  To restore the items to their original order, select the dimension and
from the Dimension menu, choose Reset.

Viewing Table Descriptions
Every Beyond 20/20 table contains descriptive information about the table. This
descriptive information, called metadata, can be found in the file summary,
dimension summaries, and item summaries.

The summary views contain an HTML viewer. The following toolbar buttons
are found in all summary views:
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Button Name Function

Home Displays the specified home page (provided you have
access to the Internet).

Back Displays the previous page in the history list. A
history list references the pages you have previously
displayed.

Forward Displays the next page in the history list.

Note:  You must use the Back button to display a
preceding page prior to using the Forward button.

Print Prints the Summary view.

Open URL
Location

Allows you to enter the URL of a page to display in
the Summary view.

Table Summaries
A table’s summary tells you something about the contents of a table. Part of it is
generated automatically by the Browser, and the remainder (if any) is added
during the preparation of the table.

À To view the summary information of a table

1. From the File menu, choose Summary.

 The Summary view appears.

 

2. Double-click on the Control-menu box to return to the table view.
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Dimension Summaries
Dimension summaries are added during the preparation of a table. These
summaries are optional, and may include information about any classification
systems being used, where and how the source data was collected, a contact
name, or reasons for any anomalies in the data.

À To view a dimension summary

 Note:  When the name in a dimension tile is underlined, a summary is
associated with that dimension.

1.  Select the dimension whose summary you want to view.

2.  Do one of the following:

• Double-click on the dimension tile.

• Click the right mouse button. Choose Dimension Summary.

• From the Dimension menu, choose Summary.

 The Dimension Summary view appears.

3.  Double-click on the Control-menu box to return to the table view.

Item Summaries
Item summaries are added during the preparation of a table. These summaries
are optional and typically provide an extended description of the active item.

À To view an item summary

 Note:  When an item heading is underlined, a summary is associated with
that item.

1.  Select the item whose summary you want to view.

2.  Do one of the following:

• Double-click on the item heading.

• Click the right mouse button. Choose Item Summary.

• From the Item menu, choose Summary.

 The Item Summary view appears.

3.  Double-click on the Control-menu box to return to the table view.
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Overview
The main component of a table is the data it contains. The Browser allows you
to:

• Change the way numbers are displayed in a cell.

• Display row and/or column distributions of the data.

• Create a working copy of all or part of a table.

• Update the data displayed in a table.

• Save only a portion of a table, or save it to a different file format.

Changing the Data Display
You can customize your view of table data by changing the way numbers are
displayed in the cells.

You can do this by:

• Increasing or reducing the number of decimal places.

• Suppressing the display of zero values.

• Changing the method used to summarize data of a time series dimension
(i.e., the aggregation method).

• Changing the unit of time used to display data of a time series dimension
(i.e., the display frequency).

Displaying Decimals
The Browser can display data values as integers or as decimal fractions. The
level of accuracy needed in the data determines whether integers or fractions
are stored in a table. In some cases (e.g., when the data in a time series
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dimension is aggregated), the Browser generates and displays fractions based on
the calculations it performs on stored integers.

Decimal places can be set for a single item, for multiple items along one
dimension, or for the entire table.

À To change the number of digits displayed after the decimal point

1. Do one of the following:

• Select one or more item headings in a dimension to set the decimal
places along those items.

• Select a dimension tile, or a single cell in the table to set decimal
places for the entire table.

2. From the View menu, choose Decimals.

3. From the cascading submenu, choose the number of decimal places you
want to display.

 A check mark appears beside the selected number.

 The decimal setting remains in effect until you change it or close the table
without first saving the view.

 To save the view, refer to “To save the current view” on page 134.

The Display Zeros Option
You can suppress the display of zero values by displaying them as empty cells.
In a table that has many zero values this option helps to make the table more
readable.

À To suppress the display of zeros in a table

1. From the Window menu, choose Preferences.

 The Preferences dialog box appears.

2. Clear the Display Zeros check box.

3. Click OK.

 From this point on, the Browser displays blank table cells when data values
are equal to zero.

Time Series Options
Time series options provide a number of aggregation methods for summarizing
data according to the display frequency you select.
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The Browser is capable of displaying data at an annual, semi-annual, quarterly,
monthly, weekly, or daily base frequency. You have the option to aggregate the
data and display it at any frequency that is lower than the base frequency.

For example, an annual, semi-annual, quarterly, or monthly display frequency
can be selected when weekly or daily data is stored in a table. An annual, semi-
annual, or quarterly display frequency can be selected when monthly data is
stored in the table.

Initially, when you open a table, time series data are displayed according to the
actual frequency at which it is stored in the table. This frequency is called the
base frequency. You can aggregate the data and display it at any display
frequency that is lower than the base frequency and you can select how the data
should be aggregated.

Example:  The following sample of data was recorded at a monthly base
frequency and was redefined and displayed at a quarterly frequency. Here is
how three of the aggregation methods would influence the data if it were
displayed at a quarterly frequency.

À To select the display frequency and aggregation method

1. From the View menu, choose Time Series.

 The Time Series dialog box appears.

Last values Averages Totals
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2.  In the Display Frequency area, select a display frequency option button that
is lower that the current base frequency.

 Note:  Dimmed option buttons are unavailable. They represent frequencies
that are higher than the base frequency.

3.  In the Aggregation Method area:

Select To

Totals display the sum of all of the values associated with each of
the underlying items for each time interval.

Averages display the quotient obtained by dividing the sum of each of
the underlying items by the total number of underlying items
for each time interval.

Minimums display the lowest data value obtained from any one of the
underlying items for each time interval.

Maximums display the highest data value obtained from any one of the
underlying items for each time interval.

First Values display the value that was recorded first (chronologically)
out of those associated with the underlying items for each
time interval.

Last Values display the value that was recorded last (chronologically) out
of those associated with the underlying items for each time
interval.

4. Click OK.

 The Browser performs the time series aggregations and displays the result
according to the display frequency you selected.

À To select advanced time series options

1. From the View menu, choose Time Series.

 The Time Series dialog box appears.
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2. In the Advanced Options area:

Select To

Percent
Change

calculate each value as the percentage increase since the previous
time interval.

The calculated value is derived from two consecutive intervals of
time. The Browser finds the difference between the two values,
divides it by the value associated with the first interval, and
displays the result as a percentage.

Moving
Averages

calculate each value as an average that is derived from a number
of values associated with an earlier time span. This has the effect
of smoothing out fluctuations in the data. You can combine up to
16 values.

 Note:  If you select the Moving Averages option button, in the Periods box,
enter the number of items the Browser should combine to make up the new
value.

3. Click OK.

 The time series calculations are performed and the result are displayed.

 Note:  If any of the values used to calculate percentage differences or
moving averages are unavailable or missing, a hyphen (-) is displayed for
the affected time interval.

Defining the Fiscal Year
The month you choose for the beginning of a fiscal year defines which month
the Browser uses to start obtaining 12-month blocks of data for time series
calculations.

À To select the start of the fiscal year

1. From the View menu, choose Fiscal Year.

 The Fiscal Year dialog box appears.

 

2. Select the start month of the fiscal year.
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3. Click OK.

 Depending on the display frequency, you may notice a difference in the
data and/or headings.

Calculating Distributions
Distribution percentages are based on your current view of a table. You can
calculate row, column and/or total distributions and include them as a new
dimension in a new table view.

À To calculate distributions

1. From the View menu, choose Distributions.

 The Distributions dialog box appears.

 

2. In the Include Items of Dimensions box, select those dimension(s) you want
to include in the distribution calculation. Note that the row and column
dimensions are automatically included in the distribution calculation. The
dimensions listed in the Include Items of Dimensions box are only those
dimensions positioned in the dimension bar. If these dimensions are not
selected, only those current items that appear in the dimension bar will be
included in the distribution.

3. In the Distribution Items area, clear any check boxes for those items you
want to exclude from the new distribution dimension.

4. Click OK.

 A distributions dimension with one to four items, depending on your
selection(s) in the Distribution Items area, is introduced into a new table
view. The new window has the same name as the original table, prefixed
with ‘Distributions:’.

 Tip:  To return to the original table view simply close the Distributions
window.
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 Notes:  If any dimensions have been nested, the sum of the data, for a
particular item, across the nested dimensions is used as the base for the
distribution calculation.

 If you have hidden any items, only the items displayed in your view are
used in the distribution calculation.

 If there are groups in your view, and any group members have been hidden,
the Browser calculates the distribution based on the remaining group
members. The group total appears as a dash.

Creating a Working Copy of a Table
Beyond 20/20 allows you to create a working copy of all or part of the current
view of a table. This option allows you to manipulate part of a table, without
affecting the original table, by placing the selected data into a worksheet. Any
table operations may be made on the worksheet, such as group calculations,
data imports, saving data to a table, etc. These operations may be made even if
the original table is read-only.

À To create a worksheet from a table

1. Select the items you want to appear in the worksheet or, using the Hide and
Show commands, display only those items you want to appear in the
worksheet.

2. From the View menu, choose Worksheet.

 The View Worksheet dialog box appears.

 

3. In the Include Items of Dimensions box, select the dimension(s) you want
to include in the worksheet. Note that the row and column dimensions are
automatically included in the worksheet. The dimensions listed in the
Include Items of Dimensions box are only those dimensions positioned in
the dimension bar of the open table. If these dimensions are not selected,
only those current items that appear in the dimension bar will be included
in the worksheet.
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4. Click OK.

 A new table view appears with the same title as the original table, prefixed
with ‘Worksheet:’.

 Note:  When the worksheet is created, if a timeseries dimension is placed
anywhere other than in the column dimension of the original table, it will
be converted to a normal dimension and timeseries operations will not be
available.

 Tip:  There is currently a limit of 8000 columns during the creation of a
worksheet. If you require more columns, place the columns in the row
dimension area before creating the worksheet, and then move them back to
the column dimension area after the worksheet has been created.

 Warning:  When a worksheet is closed, it will not be saved. To save a
worksheet, save it to a table prior to closing the worksheet. When it is
opened again, it will appear as a normal table.

Importing Table Data
Beyond 20/20 allows an existing table to be updated from another Beyond
20/20 table. For example, information providers can distribute monthly update
tables that their customers can import into existing tables containing historical
data. To import one table into another the dimensions of both tables must be the
same. If any new items are encountered as part of the update process they will
be added into the existing table.

À To import one table into another

1.  Open the table you want to update.

2.  From the File menu, choose Import.

 The Import dialog box appears.
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3.  Do one of the following:

• In the Input Filename box, enter the name of the updating table.

• Click Browse to locate and select the updating table file name.

4.  Click OK.

 Data from the updating table is loaded into the active table.

Saving Table Data
Data from a Beyond 20/20 table can be:

• Saved to another Beyond 20/20 table. This is typically done when you want
to work with a subset of a large table.

• Exported into a different file format.

• Copied into another application.

Saving Data into a New Table
You can create your own version of an existing table or a portion of one by
saving it as a new table. This is useful if you want to work with a subset of a
large table or if you want to make changes to a read-only table.

À To create a new Beyond 20/20 table from an existing one

1.  Open a Beyond 20/20 table.

2.  If required, limit the information in the table view by hiding, searching, or
switching items. For more information on any of these topics, refer to
Chapter 4, “Browser Basics,” on page 39.

3.  From the File menu, choose Save As.

 The Save As box dialog box appears.
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4.  In the File Name box, enter the name of the new table.

 If necessary, select a different drive or directory.

5.  Clear the Include Other Dimensions check box, if you do not want to save
the dimensions in the dimension bar.

6.  Click OK.

Exporting Data to a New File Format
If you want to move information from a Beyond 20/20 table to another
application, you can export data by saving it to another file format. You can
choose from a number of common file formats.

Format Description

Comma-separated value
(*.csv)

Plain text file with a comma delimiter for each
column value, and a carriage return followed by a
line feed character to identify the end of each row.

Text file (*.txt) Plain text file.

WKS worksheet (*.wks) Lotus 1-2-3 Release 1A file format.

WK1 worksheet (*.wk1) Lotus 1-2-3 Release 2 file format.

dBASE File (*.dbf) dBASE III file format.

Aremos TSD (*.tsd) Aremos file format.

À To export Beyond 20/20 table data

Note:  Any dimensions in the dimension bar whose items you want to
export must be nested before exporting. When exporting to a dBASE file,
ensure that any nesting occurs only along the rows.

Tip:   If you do not need to export the complete set of data from the existing
table, reduce the number of columns and rows in the view before exporting.
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1.  Open the table you want to export.

2.  Reduce the data in the table view by hiding items, searching for items, or
switching items into the dimension bar. For more information on any of
these topics, refer to Chapter 4, “Browser Basics,” on page 39.

3.  If necessary, nest any dimensions from the dimension bar whose items you
want to export.

4.  From the File menu, choose Save As.

 The Save As box dialog box appears.

5.  In the File Name box, enter the name of the file you want to save.

6.  In the List Files of Type box, select the file type that corresponds to the file
format you want to create.

 If necessary, select a different drive or directory.

7.  Click OK.

 The data is saved in the file format you selected.

Copying Data to Another Application
A selection of data can be transferred to another Windows application such as a
word processor or a desktop publishing product through the Windows
Clipboard.

À To copy data to the Clipboard

1. Select the cell or the items that you want to copy.

2. Do one of the following:

• Click the right mouse button. Choose Copy Cell.

• From the Edit menu, choose Copy.

 The Browser copies the selected cell or items to the Windows Clipboard.

 To paste the cells into another application, open a document in that
application, make the necessary selections, and choose the Paste command
from the Edit menu.

Printing Data
Table information can be printed from the table view and the dimension view.
The printed copy resembles the view you see on the screen.
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The header at the top of a table printout includes the table’s title and the
dimensions from the Dimension bar.

If there are columns that extend past the visible area to the right of the
document window they are printed on separate sheets of paper.

À To print table information

1. Select the table view or the dimension view you want to print.

 Note:  To learn how to open a dimension view, refer to “Displaying a
Dimension View” on page 45.

2. If necessary, limit the information in the view by hiding, searching, and
sorting the items until you have only the information you want to print.

3. Nest any dimensions you want to include in the printed copy.

 Note:  If any dimensions are left in the dimension bar, only the single item
associated with the tile is printed.

4. Do one of the following:

• Click the right mouse button. Choose Print.

• From the File menu, choose Print.

 The Print dialog box appears.

5.  Select the printing options you require.

 The options you can select from the Print Setup are common to all
Microsoft Windows applications.

6.  Click OK.

The Browser sends the print job to the printer.
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Overview
As an alternative to a table view, you can display data in a graphic format. This
chapter outlines how to:

• Display a chart view.

• Browse through items while either dynamically updating the chart or
keeping the chart constant.

• Select a different type of chart.

• Format a chart view.

• Copy and print a chart.

Displaying a Chart
When you display a chart, the Browser creates a new window and displays the
default chart in it.

À To display a chart view

1. Select the cell or the items you want to display in a chart view.

 The current arrangement of the table view and the objects you select in it
determine how the information is reflected in the chart.

2. Do one of the following:

• Click the Display Chart button on the toolbar.

• From the View menu, choose Chart.

 A chart view opens displaying the default chart.
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Identifying Chart Elements
By default, the Browser creates a two-dimensional, bar chart view from the
column and row dimensions. In addition to the data representation, a chart view
can contain four other components: title captions, a legend, a vertical axis, and
a horizontal axis. You can select, manipulate and rearrange these elements.

The following chart was created by selecting multiple columns and rows.

Title Captions

One or more title captions are displayed at the top of the chart view. Initially,
each caption contains the codes or labels associated with the dimensions and
items you did not select for display. When you select a title caption, the
associated dimension tile is highlighted in the table view.

Legend

A legend is created when you select multiple items for display. When multiple
rows are selected, or when rows and columns are selected, row labels are
displayed in the legend. When multiple columns are selected, column labels are
displayed in the legend.

Vertical Axis

The units of measure on the vertical axis are scaled automatically to
accommodate the highest and lowest data values associated with the items on
display. To learn how to change the vertical axis, refer to “Editing Axes” on
page 82.
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Horizontal Axis

The labels displayed on the horizontal axis can vary according to whether you
selected a cell, an item, or multiple items for display. The Browser displays as
many labels as possible in the space provided. If more space is required, you
can extend the horizontal axis by resizing the width of the window.

The name of the dimension associated with the horizontal axis is displayed
below the horizontal axis. When you select the dimension name, the associated
dimension tile is highlighted in the table view.

ChartBrowse
When you click on a title caption, the associated dimension tile is highlighted in
the table view; however, the chart view document window remains active.

Once you have selected a dimension in the chart view, you can perform any of
the following operations in the chart view by choosing the appropriate menu
command or toolbar button. The Browser mirrors your activity in the table
view.

• Display the next or previous item.

• Open a dimension view.

• Display any available labels associated with the item.

• Inspect a group hierarchy (if the item defines or is a member of a group).

• Find and display the item that matches the text you specify.

Note:  Only the code field and any available label fields can be searched in a
chart view. Searches on the data must be done from a table view. Also, expand
and reduce type searches are best done from a table view.

Linking and Unlinking Dimensions
You can hold an aspect of the data constant, or keep the current chart from
changing while browsing the corresponding table view. To do either, you need
to unlink the associated dimension(s) in the chart view.

Note:  With the exception of the dimension in the horizontal axis (which is
always held constant), an unlinked dimension can be linked again at any time.
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À To link or unlink a dimension in a chart view

1. In the chart view, do one of the following:

• Click the right mouse button. Choose Chart Link.

• From the View menu, choose Chart Link.

 The Chart Link dialog box appears. The Dimensions area displays the
names of all of the table’s dimensions. The check boxes that correspond to
the two dimensions plotted along the vertical and horizontal axes of the
chart are unavailable.

 

2. Do one of the following:

• In the dimensions area, select a check box to link that dimension.

• In the dimensions area, clear a check box to unlink that dimension.

• Click Link All to link all of the dimensions.

• Click Link None to unlink all dimensions.

3. Click OK.

 The dimensions are linked or unlinked. From this point on, the dimensions
will either be dynamically updated in the chart view or held constant,
according to your specifications.

Switching Items in a Chart View
After a chart view has been created, you can replace the items in the horizontal
axis and the legend. You can also add more items from the same dimension, or
switch the dimension currently on display. The corresponding labels are updated
automatically.  

Note:  Switching dimensions in the chart view does not change the linking
information. The dimension that was initially displayed in the horizontal axis
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remains unlinked. All other dimensions remain linked unless you explicitly
unlink them.

À To switch new items into a chart view

Notes:  A dimension tile can be switched into the legend or into the
horizontal axis.

Any time a single item is switched into a legend, the Browser replaces the
legend with a title caption.

1. Do one of the following:

• Click the Tile Documents button on the toolbar.

• From the Window menu, choose Tile.

2. In the table view, drag the dimension or items from the column or row
dimension, or from the dimension bar, into the chart view.

3. Do one of the following:

• Drop the dimension or items over the data in the middle of the chart
view to replace the dimension associated with the legend.

• Drop the dimension or items below the horizontal axis to replace the
items on display in the horizontal axis.
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 The items that were on display in the chart view have been replaced by the
object(s) you dragged into the chart view. The labels and data have been
updated to reflect the switch. If you switched a new dimension into the
horizontal axis, the new title caption is displayed.

Selecting Chart Options
The chart options let you change the format of the active chart view from the
default bar chart to another format. You can display the data in a bar chart, a
line chart, or a pie chart.

Initially, the Browser displays a two-dimensional vertical bar chart, or a two-
dimensional vertical grouped bar chart depending on whether you selected one
or more items. You can select among the various chart types to change the
format of the active chart view.

À To change the chart type

1. In the chart view, do one of the following:

• Click the right mouse button. Choose Chart Options.

• From the View menu, choose Chart Options.

 The Chart Options dialog box appears. The options that are available
depend on whether you selected one or more items from the column and
row dimensions.
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2. Select the chart type you want to display.

3. Do one of the following:

• Click Save As Default to apply the current selections to any future
charts you create.

• Click OK.

 The Browser resets the chart type and displays the results according to the
options you selected.

Bar Charts

The following types of bar charts are available when you select a single row or
column in the table view:

Chart
type

Description

Vertical bar chart – Creates a vertical, two-dimensional bar to
represent each item in the horizontal axis.

Horizontal bar chart – Creates a horizontal, two-dimensional bar to
represent each item in the vertical axis.

Three-dimensional vertical bar chart – Creates a vertical, 3D bar to
represent each item in the horizontal axis.

Three-dimensional horizontal bar chart – Creates a horizontal, 3D
bar to represent each item in the vertical axis.
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The following types of bar charts are available when you select more than one
row or column in the table view:

Chart
type

Description

Vertical grouped bar chart – Creates a group of vertical, two-
dimensional bars to represent a group of data points for each item in
the horizontal axis.

Horizontal grouped bar chart – Creates a group of horizontal, two-
dimensional bars to represent a group of data points for each item in
the vertical axis.

Three-dimensional vertical grouped bar chart – Creates a group of
vertical, 3D bars to represent a group of data points for each item in
the horizontal axis.

Three-dimensional horizontal grouped bar chart – Creates a group
of horizontal, 3D bars to represent a group of data points for each
item in the vertical axis.

Vertical stacked bars – Creates a group of vertical, two-dimensional
bars to represent a group of data points for each item in the
horizontal axis.

Horizontal stacked bars – Creates a group of horizontal, two-
dimensional bars to represent a group of data points for each item in
the vertical axis.

Every bar has the same color, hatch style and border assigned to it. You can
change these attributes through the Bar Chart dialog box.

Line Charts

Chart
type

Description

Vertical line chart – Creates a vertical line to join all of the X-Y
coordinates plotted for each item in the vertical axis.

Horizontal line chart – Creates a horizontal line to join all of the X-
Y coordinates plotted for each item in the horizontal axis.

Vertical line marker – Creates a vertical line with markers to join all
of the X-Y coordinates plotted for each item in the vertical axis.
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Chart
type

Description

Horizontal line marker – Creates a horizontal line with markers to
join all of the X-Y coordinates plotted for each item in the
horizontal axis.

Vertical scatter plot – Creates a marker at each X-Y coordinate
plotted for each item in the vertical axis.

Horizontal scatter plot – Creates a marker at each X-Y coordinate
plotted for each item in the horizontal axis.

Stacked line – Creates a horizontal line to join all of the X-Y
coordinates plotted for each item in the horizontal axis.

Note:  This option is only available when multiple items are
selected.

You can select line attributes, spline setting, and area characteristics for line
charts through the Line Plot dialog box. Line and marker attributes for line
marker charts can be changed through the Line Marker dialog box. Marker
attributes for scatter plot charts are assigned through the Scatter Plot dialog box.

Pie Charts

Pie charts are only available when you select one item from the column or row
dimension. When one item is selected in the row dimension, multiple items in
the column dimension can be selected.

Chart
type

Description

Pie chart – Creates a two-dimensional pie chart with each section
representing one item in the column or row dimension, whichever
dimension is inactive.

Three-dimensional pie chart – Creates a 3D pie chart with each
section representing one item in the column or row dimension,
whichever dimension is inactive.

Pie charts contain one section for each item in the inactive dimension. Each
section has a unique color, hatch style and border assigned to it. You can change
these attributes through the Pie Chart dialog box.

Displaying Footnotes
You can display the table title as a footnote at the bottom of the chart.
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À To display footnotes

1. In the chart view, do one of the following:

• Click the right mouse button. Choose Chart Options.

• From the View menu, choose Chart Options.

 The Chart Options dialog box appears.

2. In the Other Options area, select the Display Footnote check box.

3. Do one of the following:

• Click Save As Default to make all future charts reflect the current
selection.

• Click OK.

 The chart view is displayed a with footnote.

Styling and Formatting a Chart View
Once you have selected the chart type you want, you can style the view through
the styling options particular to the type of chart you selected. Each chart type
has its own unique set of styling options. Access styling options by double-
clicking on the object you want to format.

Selecting Styling Options
Because each chart type has its own set of unique styling options, a different
dialog box is displayed for formatting bars, pie sections, lines, markers, and line
markers.

À To style a chart

1.  Do one of the following:

• Double-click on the object you want to style.

• Double-click on the associated color in the legend if a legend is
available.

 The dialog box with the styling options particular to the active chart type
appears.

2.  Select the options you want to use.

3.  Click OK.

 The chart is displayed according to the options you selected.
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Selecting Fonts
The Browser provides you with a number of choices for assigning presentation
attributes to the text in a chart view. You can change the point size, font, and
color, or apply styles such as bold and italics to text.

À To change the font of the text in a chart view

1. Double-click on the text you want to format.

 The Font dialog box appears.

 

2. Select the formatting options you want to use.

3. Click OK.

Moving a Legend
The legend can be repositioned anywhere in the chart view. When you move it
to the top or bottom of the view, the legend is extended across the width of the
view.

À To move the legend in a chart view

1. Click on any part of the legend that is not being used to display text or the
color scheme.

2. Drag and drop the legend to the preferred location.

 The legend is displayed in the new location.

Adjusting the Scale of Measurement
You can manually edit the axes of a chart or use the automatic option to adjust
the scale along the axes.
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Editing Axes
You can change the settings of the axis containing the units of measurement
(usually the Y-axis).

À To edit the axis

Note:  The Edit Axis option does not apply to pie charts.

1. In a chart view, double-click on the axis containing the units of
measurement.

 The Edit Axis dialog box appears.

 

2. In the Minimum box, enter the desired lower limit for the axis.

3. In the Maximum box, enter the desired upper limit for the axis.

4. In the Tick Space box, enter the desired width between major ticks on the
axis.

5. In the Minor Ticks box, enter the number of minor ticks you want to appear
between major ticks.

6. Click OK.

 The chart view is displayed with the edited axis. If the coordinate for an
item exceeds the capacity of a chart, it is either cut off at the point where
the measurement ends (for bar charts), or it is plotted outside the confines
of the chart (for line, marker, and scatter plot charts).

Setting Axes Automatically
You can automatically adjust the scale that is used to measure data values. The
adjustment accommodates both the highest and the lowest data values so that all
of the selected data points can be displayed at once. This feature is useful when
comparing charts side-by-side.
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You can automatically set the axis through the Edit Axis dialog box or the Chart
Options dialog box. If you have defined minor tick spaces and use the Edit Axis
dialog box, the tick spaces remain in the new axis.

À To set the axis automatically through the Edit Axis dialog box

1. In the chart view, double-click on the axis containing the units of
measurement.

 The Edit Axis dialog box appears.

2. Click Automatic to set the axis automatically.

À To set the axis automatically through the Chart Options dialog box

Note:  When the Auto Axes check box is clear, the scale that was applied to
the chart you created previously is used.

1. In the chart view, do one of the following:

• Click the right mouse button. Choose Chart Options.

• From the View menu, choose Chart Options.

 The Chart Options dialog box appears.

2. In the Other Options area, select the Auto Axes check box.

3. Do one of the following:

• Click Save As Default to make all future charts reflect the current
selection.

• Click OK.

Switching Axes
You can switch the dimension currently on display in the horizontal axis with
the dimension displayed in the legend.

À To switch the axes in a chart view

1. In the chart view do one of the following:

• Click the right mouse button. Choose Switch Axes.

• From the View menu, choose Switch Axes.

 The data is displayed in the chart view with the horizontal and legend
labels interchanged.
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Copying a Chart
A copy of a chart can be transferred to another Windows application such as a
word processor or a desktop publishing product through the Windows
Clipboard.

À To copy a chart to the Clipboard

1. In the chart view, do one of the following:

• Click the right mouse button. Choose Copy.

• From the Edit menu, choose Copy.

 The Browser copies the chart you selected to the Windows Clipboard.

 To paste the chart view into another application, open a document in that
application, make the necessary selections, and choose the Paste command
from the Edit menu.

Printing a Chart
When a chart is printed, the Browser adjusts the aspect ratio of the view
automatically. This means that the printed chart view is as wide as the printed
page, and the height of the chart is adjusted automatically in proportion to its
width.

À To print a chart

1. In the chart view, do one of the following:

• Click the right mouse button. Choose Print.

• From the File menu, choose Print.

The Browser sends the print job to the printer.
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Overview
As an alternative to a table view, you can present table data in a geographic
context – provided a map file is available with the table. This chapter details
how to:

• Display a map view.

• Represent data values on a map.

• Magnify and view composite regions of a map.

• Format a map view.

• Copy and print a map.

Displaying a Map
All maps provide a representation of the geographic dimension. You do not
need to make a particular selection in the table view to display a map. Each
item in a geographic dimension automatically corresponds to a single region or
city on a map. Any region that corresponds to a hidden item is dimmed in the
map view.

A map can only be displayed when a Beyond 20/20 map file is available with
the table.

À To display a map

1.  In the table view, do one of the following:

• Click the Display Map button on the toolbar.

• From the View menu, choose Map.

 The map view is displayed.
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Identifying Map Elements
The map view contains title captions, a legend, the data values associated with
each region, and a footnote. You can select, manipulate, and rearrange these
elements.

Title Captions

One or more title captions are displayed at the top of the map view. The
captions contain dimension names and labels corresponding to the intersecting
items associated with the current position of the cursor in the table view.

Legend

The legend shows you which colors are currently assigned to represent the three
ranges of data, as determined by the range definition. You can assign a different
color to represent each range. For more information, refer to “Selecting Range
Colors” on page 89. The legend also indicates the specific range of values that
meet the current range definition. The legend is updated automatically.

Data Values

By default, there is one data value displayed per region. Data values are derived
from the item that corresponds to that region and are influenced by the range
definition.

Range Colors

The Browser uses color to represent the three ranges of data (low, middle, and
high). To classify the data values into a range, the Browser evaluates the data
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according to the Range Definition options you select. As a result, the associated
items are classified into one of the low range, middle range, or high range,
according to the relative significance of their data. For more information on
selecting ranges, refer to “Assigning Range Definitions” on page 88.

MapBrowse
When you click on a title caption, the associated dimension tile is highlighted in
the table view; however, the map view document window remains active.

Once you have selected a dimension in the map view, you can perform any of
the following operations in the map view by choosing the appropriate menu
command or toolbar button – the Browser mirrors your activity in the table
view.

• Open a dimension view.

• Display any available labels associated with the item.

• Inspect the hierarchy of groups.

• Find and display the item that matches the text you specify.

 Note:  Only the code field and any available label fields can be searched in
a map view. Searches on the data must be done from the table view. Also,
expand and reduce type searches are best done from the table view.

Selecting Map Options
Each region and city has a label, a data value, and a color to indicate the
assigned range definition.

You can select map options to determine:

• The method used to evaluate data and assign a range definition to the
corresponding items.

• The colors used to represent the three data ranges.

• Whether cities are displayed.

• Whether labels, data values and a footnote are displayed.

• How the range definition is applied to select which range of region labels
are displayed.

• Whether the map view is updated.

The options you select apply only to the current map view.
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Assigning Range Definitions
The Browser evaluates the data associated with each item according to the
current setting of the Range Definition options. At the conclusion of the
evaluation phase, each item is assigned a range definition (low, middle, or
high). The range definition determines the color of a region (and/or the area
around a city), and it classifies the item’s label and data values for display
purposes.

In all cases, the region or city associated with the highest data value is
highlighted in the high range color, and the region or city associated with the
lowest data value is highlighted in the low range color. The color that is applied
to the regions and cities with middle range values varies according to the range
definition you selected.

In most cases, during the evaluation phase, the Browser calculates the average
of all values to adjust the distribution of colors for middle range values. A
middle range value is assigned a color according to whether it is higher or lower
than the average.

À To assign range definitions

1. In the map view, do one of the following:

• Click the right mouse button. Choose Map Options.

• From the View menu, choose Map Options.

 The Map Options dialog box appears.
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2. In the Range Definition area:

Select To

High/
Low

highlight the regions with the highest data in the High Range
color and the regions with the lowest data in the Low Range
color. All data that falls in between is highlighted in the
Middle Range color.

Standard
Deviation

highlight all regions whose data falls within one standard
deviation of the average in the middle range color. All
regions with data values greater than the average are
highlighted with the high range color. All regions with data
values less than the average are highlighted with the low
range color.

Average compare the data values to the average value (which was
derived from all values). All values higher than the average
are highlighted with the high range color. All values lower
than the average values are highlighted with the low range
color. Only data values that match the average exactly (if
any exist) are highlighted with the middle range color.

Linear highlight all regions with a blend of high and low range
colors. The middle range color is not used. All regions
whose data values are greater than the average have a higher
proportion of the high range color. All regions whose data
values are less than the average have a greater proportion of
the low range color.

Bilinear highlight all regions with a blend of high, middle and low
range colors. Regions whose data values are closest to the
highest data value have the highest proportion of the high
range color. Regions whose data values are closest to the
middle value have the highest proportion of the middle
color. Regions whose data values are closest to the lowest
data value have the greatest proportion of the low range
color.

3. Click OK.

 The Browser calculates the average of all values and adjusts the
distribution of colors for the range values according to the definition option
you selected.

Selecting Range Colors
You can select a color to represent the highest value (high range color), the
lowest value (low range color), and all of the data in between (middle range
color). The Browser adjusts the distribution of these colors automatically
according to the evaluation method you select in the Range Definition area. For
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more information about Range Definition Options, refer to “Assigning Range
Definitions” on page 88.

À To select range colors

1. In the map view, do one of the following:

• Click the right mouse button. Choose Map Options.

• From the View menu, choose Map Options.

 The Map Options dialog box appears.

2. In the Range Colors area, select the colors you want to use to define the
low, middle and high ranges.

3. Click OK.

 The distribution of colors is adjusted according to your selections.

Displaying Region Labels

À To display region labels

1. Open the map view you want to change.

2. Do one of the following:

• Click the right mouse button. Choose Map Options.

• From the View menu, choose Map Options.

 The Map Options dialog box appears.

3. In the Contents area:

Select To

Display Region
Names

display labels associated with the regions on the map.

Note:  Select the Show Cities check box to display
labels associated with cities, provided the information
is available.

Display Data
Values

display data values associated with the regions on the
map.

Note:  Select the Show Cities check box to display data
values associated with cities, provided the information
is available.

Display Footnote display the table title as a footnote.

 Note:  When you select an option in the Contents area, you must also select
one or more options in the Display area to qualify it.
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4. In the Display area:

Select To

Show Low Range
Labels

display the label or data value associated with every
region that falls into the low range definition.

Show Middle
Range Labels

display the label or data value associated with every
region that falls into the middle range definition.

Show High Range
Labels

display the label or data value associated with every
region that falls into the high range definition.

Hide Zero Labels hide labels displaying a zero value.

 Note: The Browser does not let you make any selections in the Display
area until you make a selection in the Contents area.

5. Click OK.

 The map view displays the selections you specified.

Displaying Cities
Each city has a label (city name) and a data value. If you want to see the labels
and/or data values associated with cities, you must select the corresponding
options from the Contents and Display areas in the Map Options dialog box.
The selections you make for cities in the Region Labels and in the Range
Colors areas affect the way colors, labels, and data values for all other items are
displayed. For more information, refer to “Displaying Region Labels” on page
90.

Note:  The Show Cities option is only effective when cities are associated with
the table.

À To display cities

1. In the map view, do one of the following:

• Click the right mouse button. Choose Map Options.

• From the View menu, choose Map Options.

 The Map Options dialog box appears.

2. In the Cities area, select the Show Cities check box.

3. Click OK.

 The map view displays the labels and/or data values for any cities.
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Linking and Unlinking a Map
When you link a map to a table, the map view is automatically updated as you
browse the table. For example, from the table view, if you move to the next
item of a dimension in the dimension bar, the appropriate title caption and
display of the map will reflect the new item.

À To link or unlink a map

1. In the map view, do one of the following:

• Click the right mouse button. Choose Map Options.

• From the View menu, choose Map Options.

2. Do one of the following:

• Select the Link Map to Data check box to link the map view to the
table view.

• Clear the Link Map to Data check box to unlink the map view from the
table view.

3. Click OK.

 Depending on your selection, the map view is either held constant or is
updated as you browse through items in the table.

Changing the Layout of a Map

Zooming In or Out of a Region
The items in a geographic dimension are typically structured into groups –
smaller regions or cities are grouped to comprise a larger region.

Initially, the smaller areas are not visible in the map view – only the larger areas
are displayed. However, you can zoom into a region that comprises smaller
areas to see the data associated within the constituent areas. When you are
looking at a number of smaller regions, you can zoom out to view the larger
region.

À To zoom into a region

1. Select a region that has constituent regions assigned to it.

 Note:  To determine whether the active region contains groups (constituent
regions), select the region and check the status bar. If the letter T, P, or C is
displayed, the region contains a total, protected, or computed group. For
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more information on groups, refer to “Examining Group Levels” on page
46.

2. Do one of the following:

• Double-click on the region that interests you.

• Click the right mouse button. Choose Zoom In.

• From the View menu, choose Zoom In.

 The Browser displays the constituent regions that are assigned to the active
region.

À To zoom out of a region

1. Select any region that is part of a larger region.

 Note:  To determine whether the active region is part of a larger region,
select the region and check the status bar. If the letter M is displayed, the
region is part of a larger region. For more information on group members,
refer to “Examining Group Levels” on page 46.

2. Do one of the following:

• Double-click on any white space surrounding the map.

• Click the right mouse button. Choose Zoom Out.

• From the View menu, choose Zoom Out.

 The Browser displays the larger region and all of the surrounding areas.

Magnifying Part of a Map View
If you have zoomed in on a region as much as possible and you want to get a
closer look, you can magnify a portion of the map view. A magnified view gives
you a better idea of where the boundaries of a region are.

À To magnify part of a map view

1. Hold the Shift key down and click on the part of the map you want to
magnify.

2. Drag the cross-hair pointer across the part of the map you want to magnify.

3. Release the mouse button and the Shift key.

 The Browser magnifies the area you selected.

 Tip:  To quickly magnify a region so that it fills the display area, hold the
Shift key down and click on the region that interests you.
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À To restore a magnified map view to normal size

1.  Do one of the following:

• Click the right mouse button. Choose Restore.

• From the View menu, choose Restore.

 The map is restored to its original view.

Moving a Legend
The legend can be moved anywhere in the map view.

À To move the legend

1. Click on any part of the legend that is not being used to display text or the
color scheme.

2. Drag and drop the legend to the preferred location.

 The legend is displayed in the new location.

Moving Region Labels
Region labels can be moved anywhere inside the border of the map view,
except on top of the legend.

À To move a region label

1. Position the mouse pointer over the region label you want to move.

2. Hold the Shift key down and drag and drop the region label to a new
position.

Copying a Map
A copy of a map can be transferred to another Windows application such as a
word processor or a desktop publishing product through the Windows
Clipboard.

À To copy a map to the Clipboard

1. Click on the map you want to copy.

2. Do one of the following:

• Click the right mouse button. Choose Copy.
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• From the Edit menu, choose Copy.

 The Browser copies the map you selected to the Windows Clipboard.

 To paste the map view into another application, open a document in that
application, make the necessary selections, and choose the Paste command
from the Edit menu.

Printing a Map
When a map is printed, the Browser adjusts the aspect ratio of the view
automatically. This means that the printed map view is as wide as the printed
page, and the height of the map is adjusted automatically in proportion to its
width.

À To print a map

1. Click on the map you want to print.

2. Do one of the following:

• Click the right mouse button. Choose Print.

• From the File menu, choose Print.

 The Print dialog box appears.

3. Select the print options you require.

The Browser sends the print job to the printer.
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Overview
An extract is an encoded and compressed form of a source file. Extracts are
used to create multi-dimensional tables.

When working with extracts, you can:

• Locate, and browse the contents of an extract.

• Customize source fields prior to creating a table by: applying record
constraints, redistributing items, redefining ranges, and applying arithmetic
operations.

• Fill a table with values that are sums or averages of a numeric source field,
or values that are weighted.

• Create and save a table.

• Export an extract to a new file format.

Finding and Opening Extracts
To create your own table, you must first locate and open an extract. You can
find and open an extract using the Find command from the File menu. For more
information, refer to Chapter 3, “Finding and Opening Tables and Extracts” on
page 33.

Viewing an Extract Summary
An extract summary contains textual information which describes the contents
of the extract. Some of this information is provided by the extract creator and
the rest is generated automatically by Beyond 20/20.
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À To browse an extract summary

1. From the Data menu, choose Extract Summary.

 The Extract Summary view appears.

 

2. Double-click on the Control-menu box to return to the extract.

Finding Source Fields
Source fields are the components of an extract from which you create a table.
When source fields are positioned into an empty table view, they become
dimensions.

From within an extract you can view the contents of a source field (i.e., its
dimension view) by double-clicking on the source field you want to explore.

À To open the Find Source Field dialog box

1. From the Data menu, choose Find Source Field.

 The Find Source Field dialog box appears.
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 With the Find Source Field dialog box open you can:

• Select one or more categories to create a list of source fields assigned
to those categories.

• Search for source fields according to criteria you specify.

• View a source field summary.

• Find a source field.

 If you know exactly which source field you are looking for, proceed to
“Locating a Source Field” on page 101.

Selecting Categories to Find Source Fields
When you open the Find Source Field dialog box, the Categories box displays
all of the category names that are assigned to the source fields. The Fields/Type
box provides you with a list of all of the source fields assigned to that category.

À To select one or more source field categories

1. In the Categories box, select the category name that interests you.

2. To select more than one category, do one of the following:

• Click on and hold the left mouse button while dragging the pointer
along the category names.

• Hold the Ctrl key down and click on the category names.
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 Each time you add a new category to those selected, the Browser adds the
associated source fields to the Fields/Type box.

Searching for Relevant Source Fields
Each source field has descriptive components that provide information about
the contents of the source field.

The descriptive components correspond to several fields of text. You can search
the text in these fields to find a source field that contains the information you
are looking for.

À To search a source field's descriptive components

1. From the Find Source Field dialog box, select one or more categories you
want to search.

2. Click Search.

 The Find Source Field Search dialog box appears.

 

3. In the Text to Find box, enter the symbols or text you want to search for.

4. In the Search Options area, select the fields you want to search.

Component The kind of text it contains

Title/Description A brief description of the source field.

Notes An extended description of the source field.

Keywords A list of individual words or phrases that relate to the
contents of the source field.

Dimension/Source
Field Names

The name of the source field.

Codes The codes associated with the source field. A code is
a symbolic value that uniquely identifies an item.
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Component The kind of text it contains

Labels The labels associated with the source field. A label is
a word or phrase that describes an item, or the code
which identifies that item.

5.  Click OK.

 The Browser compares the symbols or text you specified to the text stored
in the source field’s descriptive components. Any matching source fields
are displayed in the Fields/Type box and the total number found is
displayed above the box.

 If a match is not found, the Field/Type box is empty and the message ‘0
found’ is displayed above it. In this case, you may want to clear the result
in the Find Source Field dialog box, and try a different search.

Viewing a Source Field Summary

À To view a source field summary

1. From the Find Source Field dialog box, in the Fields/Type box, select the
source field you want more information about.

2.  Click Summary.

 The Source Field Summary dialog box appears.

3.  Click OK to return to the Find Source Field dialog box.

 Tip:  You can view a source field summary at any time. To do this, select
the source field tile and from the Data menu, choose Source Field
Summary.

Locating a Source Field

À To locate a source field

1. Do one of the following in the Find Source Field dialog box:

• In the Fields/Type box, double-click on the source field you want to
locate.

• In the Fields/Type box, select the source field you want to find. Click
OK.

 The source field tile is highlighted on the source field bar.
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Creating Custom Source Fields
You can create your own source fields based on the source fields provided in an
extract. Once created, these new source fields become part of the extract and
remain in the extract until you delete them. You can use these custom source
fields to create custom dimensions in tables of your own design. Each of the
following operations creates a new source field.

Recoding Source Fields
Recoding a source field allows you to create a new source field which contains
a redistribution of the items from the original source field. For example, if the
original source field contains items for small geographic regions (e.g., states or
provinces), you can recode the items to create a new source field for larger
geographic regions (e.g., the Midwest or Atlantic region).

Note:  When recoding a source field, all codes in the original source field must
be assigned to the recoded source field.

The Define Recode dialog box allows you to create a new source field and enter
the new codes.

À To recode a source field

1. Do one of the following:

• Click the right mouse button on the source field tile you want to
recode. Choose Define Recode.
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• From the Data menu, choose Define Recode.

 The Define Recode dialog box appears and the active source field displays
in the Source Field Name box.

 Note:  If the Source Field Name box does not contain the field you want to
recode, select the appropriate field from the Source Field Name drop-down
list box.

2. In the New Source Field Name box, enter a name for the new source field,
or use the default name displayed.

 The existing codes for the source field are displayed in the Available Codes
box.

3. In the New Code box, enter a name for the new item.

4. Define or modify the codes that will make up the new item.

To Select

Add members the codes in the Available Codes box. Click Add.

Remove members the codes in the Members box. Click Remove.

 Tip:  To select non-consecutive codes, hold the Ctrl key down and click on
each code. To select consecutive items, click on the first code, hold the
Shift key down, and click on the last code.

5. Repeat from Step 3 for each item in the new source field.

6. If codes remain in the Available Codes box that are not to be recoded,
select them and click Use As Is.

7. When all available codes have been reassigned, the OK button becomes
available. Click OK.

 You are prompted to confirm the creation of a new field.

8. Click OK.

 A new source field tile appears in the source field bar.

Creating New Bands for Numeric Source Fields
When an extract is created, default numeric bands are assigned to all numeric
source fields without an associated dimension definition file. You can modify
these bands with the Define Bands command. For example, if an original age
source field contains 5-year age bands it can be rebanded to produce 10-year
bands.

The Define Bands dialog box allows you to reband an existing numeric source
field.
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À To create bands of equal size

1. Do one of the following:

• Click the right mouse button on the numeric source field you want to
reband. Choose Define Bands.

• From the Data menu, choose Define Bands.

 The Define Bands dialog box appears.

 Notes:  If the Source Field Name box does not contain the field you want
to reband, select the appropriate field from the Source Field Name drop-
down list box.

 The Code/Description box displays one code containing the true minimum
and maximum values of the source field.

2. In the New Source Field Name box, enter a name for the new source field,
or use the default name displayed.

3. If you want to create custom bands or modify existing bands, proceed to
“To create custom bands” on page 105.

4. In the Start box, enter a value that is equal to or less than the lowest value
in the Code/Description box.

5. In the Increment box, enter a value to be used as the constant width for all
bands.
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 Note:  When you enter a value in the Start or Increment box, the OK button
dims to prevent you from creating a new source field before the bands are
applied.

6. Click Apply.

 The Browser assigns the bands necessary to contain all values in the source
field and displays them in the Code/Description box.

7. If you want to modify these bands, proceed to “To create custom bands” on
page 105.

8. Click OK.

 You are prompted to confirm the creation of a new field.

9. Click OK.

 A new source field tile appears in the source field bar.

À To create custom bands

1. From the Define Bands dialog box, click Advanced.

 The Define Band area is displayed at the bottom of the dialog box.

2. In the Define Band area, enter the following options:

In the Type

New Code box a character combination representing the new code.

Minimum box the value that will be the lower threshold of the band.

Maximum box the value that will be the upper threshold of the band.

3. Select the following check boxes:

Select If you want the Browser to

Renumber sequentially renumber the numeric codes.

Inclusive include the value in the minimum or maximum box in the
band. If you want all but the value to be included, clear the
Inclusive check box.

 Note:  In the display of a band, an inclusive endpoint is denoted by a
square bracket and an exclusive endpoint is denoted by a round bracket.

4. In the Create New Field as area, select the option button corresponding to
the field type for the new source field. Select numeric if you subsequently
want to reband or perform operations on the new field.

5. Click OK.

 You are prompted to confirm the creation of a new field.
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6. Click OK.

 A new field tile appears in the source field bar.

Deriving New Source Fields Using Arithmetic Operations
You can derive new source fields by combining arithmetic operations and
existing source fields in formulae. The formulae can include ‘if,’ ‘then,’ ‘else,’
and ‘endif’ expressions to allow for conditional constructs. The result of a
formula is a numeric field.

There are a number of rules which must be followed when designing these
formulae:

• The following arithmetic operators may be used: +(add), -(subtract),
*(multiply), /(divide), and ^(raise to the power).

• The following relational operators may be used: <(less than), <=(less than
or equal to), =(equal to), >=(greater than or equal to), >(greater than), and
<>(not equal to).

• In an expression, ^ is evaluated before * and / which are in turn evaluated
before + and -. Otherwise, evaluation proceeds in a left to right order.

• Round brackets ( ) are used to alter the order of execution.

• If, then, else, and endif constructs are used to create more complex
formulae. All four words (if, then, else, endif) must be included in your
constructs.

• Square brackets must be used around source field names containing special
characters (e.g., blanks or _ ). For example, [Field One].

• You may use coded fields in the condition of an if, then, else construct, but
you must use quotes around the code (e.g., Sex =“1”).

Here are some examples of formulae:

Formula New field contains

Salary*1.1 Salary multiplied by 1.1

(Age+20)/2 (Age plus 20) divided by 2

if Age >40 then Salary*1.05 else
Salary*1.15 endif

If Age is greater than 40, then Salary is
multiplied by 1.05; if Age is less than or
equal to 40, Salary is multiplied by 1.15.

if Sex = “1” then 0 else Salary*1.1 endif If Sex = code 1, zero; otherwise Salary is
multiplied by 1.1

The Define Derived Field dialog box allows you to create a new source field by
combining arithmetic operations with existing source fields.
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À To derive a new source field

1. From the Data menu, choose Define Derived Field.

 The Define Derived Field dialog box appears.

2. In the New Field Name box, enter a name for the new field.

3. In the Formula box, enter an expression to describe how the new field is to
be calculated.

 Tip:  To include an existing source field in your formula, double-click on
the appropriate field name in the Available Fields box or highlight the field
name you want to include and choose Insert.

4. Click OK.

 You are prompted to confirm the creation of a new field.

5. Click OK.

 A new source field tile appears in the source field bar.

Creating a Table from an Extract

Planning a Table
The following points outline some of the things you should consider before
creating a table:

• Determine what purpose the table will serve and what questions it should
answer. This will help you decide what the dimensions should be and if you
want to create any customized source fields.

• Decide on the order of the dimensions. The order you set determines the
default view when a table is opened.
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• Determine if there is textual information available that describes the table
and/or the dimensions and items.

Positioning Tiles for Dimensions
To position source fields as dimensions, drag and drop the source field tiles into
the row, column, and dimension bar areas of the table view.

À To position tiles

 Notes:  A table can have to up ten dimensions. Place the first dimension in
the row dimension area, the second in the column dimension area, and the
rest on the dimension bar. Dimensions can be rearranged any time before
you click the Go button.

 If there is a date field in your source file, you should place it in the column
dimension area to take advantage of Beyond 20/20’s time series features.

1. Click on the source field tile you want to appear in the table and hold down
the left mouse button.

2. Drag the tile into a dimension area.

3. Release the mouse button.

 The dimension tile appears in the table view and the corresponding source
field tile is dimmed in the source field bar.

4. Repeat from Step 1 for each source field that you want to appear in the
table.

Filling a Table With Numeric Source Field Values
You can fill a table with values that are sums or averages of numeric source
fields instead of counts or weighted counts.

À To fill a table with numeric source field values

1. Drag and drop a numeric source field into the cell area of the table view.
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 The Edit Unit Item dialog box appears. The name of the source field you
dragged into the cell area is displayed as the Based on Field.

 

2. In the Item Name box, confirm or change the name you want to give the
new item.

3. In the Calculated As box, select the statistical method you want to apply.

 An asterisk appears in the source field tile to indicate that the Browser has
created a new item in the “Units” dimension based on this source field.

 Tip:  You can use the same source field several times to calculate different
units for that field. Or, you can fill the table with several source fields by
dragging them individually and dropping them into the table. An individual
item is created in the Units dimension for each combination of source field
and statistical method you include.
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Setting Record Constraints
When you want to limit the source records that are loaded into a table, or create
a new extract whose underlying data has been constrained, you can apply record
constraints.

The Record Constraints view allows you to:

• Impose one or more constraints on all records during the creation of a table.

• Impose one or more constraints before creating a new extract.

À To set record constraints

1. From the Data menu, choose Record Constraints.

 The Record Constraints view appears. It consists of columns, each
potentially representing a constraint.

2. Select the source field you want to use to create a constraint and drag it into
the first empty column in the view. If the non-numeric field does not have a
dimension definition file associated with it you are prompted to confirm the
creation of one.

 The source field name appears in the Field row.

 Notes:  If the source field is numeric, the lowest and highest data values
appear in square brackets in the Criteria row (e.g., [18, 89]).

 If the field is coded, the codes related to the source field appear in
quotation marks preceded by an equal sign in the Criteria row (e.g., =“4”).

3. Double-click on the text in the Criteria row.
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• If the text you select is numeric, the Numeric Constraint dialog box
appears.

 
• If the text you select is coded, the Constraint Field dialog box appears.

 
4. 

In the Select

Numeric Constraint
dialog box

a range or comparison constraint.

Notes:  If you select a range constraint, enter the
minimum and maximum values to be included in
the constraint. Select Inclusive to indicate that
the range used to constrain the source field is
inclusive of the minimum and maximum values.

If you select a comparison constraint, choose a
comparison operator and, in the Value box, enter
the value you want to use as the constraint.
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In the Select

Constraint Field
dialog box

the codes you want to include in the constraint.

Tip:   To select non-consecutive codes, hold the
Ctrl key down and click on each code. To select
consecutive codes, click on the first code, hold
the Shift key down, and click on the last code.

5. Click OK.

 The Record Constraints view appears.

6. Repeat from Step 2 for each source field you want to impose constraints on.

 Tip:   If you make a mistake, simply drag the source field back to the
source field bar.

 Note:  As you drag and drop the source fields into the columns, a single
vertical line separates the columns that are filled. This indicates an And
condition, where the Browser will search for records that match all of the
constraints in each of the columns.

 

7. If you want to indicate an Or condition, select a column and click Or. A
separation and the word Or appear to the right of the selected column
indicating that the Browser will search for records that match the
constraints in either column (or group of columns).
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Note:  To change the Or condition back to an And condition, click And.

8. If you want to constrain the data that will be loaded into the table, close the
view.

 The constraints are applied and are detailed in the notes section of the table
summary when the table is created.

 Note:  Constraints may be modified at any time before the table is created.

9. If an extract is open and you want to create a new extract that contains
records according to the constraints specified, from the File menu, choose
Save Extract As.

 The Save As dialog box appears.

10. Save the new extract.

 An extract containing only the data that satisfies the constraints is created
and an associated set of dimension definition files are saved. The new
extract is independent of the original extract.

Applying a Weighting Factor to the Data
If you are working with an extract that represents data collected from a survey
there will probably be at least one field that contains weights. These weights are
used to generate population-based tables from sample survey data. An extract is
pre-weighted if one of the weight fields is dimmed in the Source Field bar.
Tables built from a pre-weighted extract will automatically contain weighted
values.
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You can use any numeric source field as a weighting factor during table
creation.

The Set Weight Field dialog box allows you to select the field that contains the
weighting factors to use.

À To set a weight field

1. From the Data menu, choose Set Weight Field.

 The Set Weight Field dialog box appears. Only numeric fields from the
source file are displayed.

2. Select the Use Weight Field check box.

3. Select the field that you want to use as the weight field.

4. Click OK.

 The source field selected to weight the data appears dimmed in the source
field bar indicating it is unavailable for use as a dimension.

 Note:  When a weighted table is created the notes section of the table
summary indicates which field was used as the weight field.

Setting Processing Options
With the Table Options command, you can control whether a table supports
missing values, is multilingual, and whether or not Browser users can modify
the table.l

The Table Options dialog box allows you to enable missing values, make the
table read-only for Browser users, and define the language(s) for a multilingual
table.
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À To set table options

1. From the Data menu, choose Table Options.

 The Table Options dialog box appears.

2. If you want to enable missing values, in the Missing Values Support area:

Select If you want the Builder to

Missing Values Not
Enabled

display zeros in the cells of the table to indicate that
no source data for that cell was found.

Table Initialized to
Missing Values

initialize all cells of the table to dashes before the
source file is processed.

Table Initialized to Zero
Values

initialize all cells of the table to zeros before the source
file is processed.

 Once a table is created, you cannot change the missing values support. To
determine if the missing values option was enabled when the table was
built, check the table’s summary statistics.

3. If you are creating a multilingual table, proceed to “To set the default
language” on page 115.

4. Click OK.

À To set the default language

1. From the Data menu, choose Table Options.
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 The Table Options dialog box appears.

2. In the Default Language drop-down box, select the language the table
should be opened in.

 You are prompted to confirm the default language.

3. Click Yes.

 You are prompted that once you set the default language you cannot change
it.

4. Click OK.

À To add support for additional languages

1. From the Data menu, choose Table Options.

 The Table Options dialog box appears.

2. In the Support Languages box, select one or more additional languages for
the table.

 Selected languages are highlighted.

3. Click OK.

 Notes:  To remove a language, in the Support Languages box, click on the
language to clear the selection.

 You cannot remove the default language.

Loading Data Into the Table
Once you have defined the table by positioning a minimum of two source field
tiles as dimensions and optionally filling the table with numeric source values,
you are ready to create the table.

Note:  Since tables created from extracts are processed in memory, the size of
the table is limited by the amount of available memory.

À To create the table

1. Do one of the following:

• Click the Go button on the toolbar.

• From the Data menu, choose Go.

 The table is created and the table view is displayed.
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 Note:  The extract file remains open, allowing you to build additional
tables.

Next Steps:

To provide additional descriptive information about the table, refer to
“Documenting a Table” on page 135.

To add fields, labels, items or groups to a dimension, refer to Chapter 9,
“Customizing Tables and Extracts,” on page 121.

To save the table, proceed to “Saving the Table” on page 117.

Saving the Table

À To name and save the table

1. From the File menu, choose Save As.

 The Save As dialog box appears.

2. In the File Name box, enter the name of the table.

 If necessary, select a different drive or directory.

3. In the List Files of Type box, select Data Table (*.ivt).

4. Click OK.

Next Steps:

To provide additional descriptive information about the table, refer to
“Documenting a Table” on page 135.

To add fields, labels, items, or groups to a dimension, refer to Chapter 9,
“Customizing Tables and Extracts,” on page 121.

Utilities

Sorting Source Field Tiles
Source field tiles are listed in the source field bar. Each of the tiles represents a
source field which can be used as a dimension or a unit of measurement during
the creation of a table. These tiles can be listed either alphabetically, or in the
order in which they were created by the Builder.

À To sort source field tiles

1. From the Window menu, choose Preferences.
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 The Preferences dialog box appears.

2. Do one of the following:

• Select the Sort Source Field Tiles Alphabetically check box to display
the source field tiles in alphabetical order.

• Clear the Sort Source Field Tiles Alphabetically check box to display
the source field tiles in the order in which they were created.

3. Click OK.

 The source field tiles are sorted according to your specifications.

Deleting a Source Field
You can delete source fields that you no longer require.

À To delete a source field from an extract

 Warning:   Once a source field is deleted, you cannot retrieve it.

1. Select the source field you want to delete.

2. Do one of the following:

• Click the right mouse button. Choose Delete Source Field

• From the Data menu, choose Delete Source Field.

 The Browser asks you to confirm that the field you have selected is really
the one you want to delete.

3. Click OK.

 The source field is permanently deleted.

Recreating an Extract
If you receive a message trying to open an extract indicating that the Browser
cannot find a file associated with the extract, you must recreate the extract.

You can recreate an extract from either the extract file or one of its constituent
dimension definition files.

À To recreate an extract

1. From the File menu, choose Utilities, then Recreate Extract.

 The Recreate Extract dialog box appears.
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2. In the File Name box, enter or select the name of the extract file, or one of
its constituent dimension definition files, that you want to recreate.

 If you do not see the file you want to recreate, select a different drive or
directory to locate the file.

3. Click OK.

 Tip:  If you have the extract open when you recreate it, you must close and
reopen it to get an updated copy.

Exporting an Extract to a New File Format
The Browser allows you to export a Beyond 20/20 extract to another file
format. This facilitates the transfer of source field data into other software
packages.

If you have applied any constraints, the Browser allows you to save only those
records that match the constraints.

You can choose from these file formats.

Format Description

dBase File (*.dbf) dBase III file format.

SAS File (*.sas) SAS file format.

SPSS File (*.sps) SPSS file format.

À To export an extract to a new file

1.  Open the extract you want to save as a new file.

2.  From the File menu, choose Save Extract As.

3.  In the File Name box, enter the new file name.

 If necessary, select a different drive or directory.

4.  Click OK.

 The Export Extract dialog box appears.

5.  In the Available Fields box, select the fields you want to export.

6.  If you have applied any constraints and want to save only those records that
match the constraints, select the Apply current constraints check box.

7.  Click OK.

Note:  When exporting an extract to a SAS or SPSS file format, two files
are created. The text file (.txt) contains the data and the SAS (.sas) or SPSS
(.sps) file contains the file layout and description information.





Chapter 9:  Customizing Tables and
Extracts

Overview
After creating or browsing a table, you may want to customize it to better suit
your needs. The following Browser activities provide you with the tools to do
this:

• Create groups of items to establish a hierarchy or create totals.

• Add fields to a dimension and either manually add or import labels.

• Save one or more views of the table.

• Document a table by adding table, dimension and item summaries.

Groups
A group is an item that has an underlying hierarchy associated with it. A total
group is one whose data values have been created by summing those members
of the group. A protected group defines a hierarchy, however its data values are
independent of the items in the group. A computed group is calculated by
applying formulas to selected items.

When the cursor is on a cell that either defines a group or is a member of a
group, the status bar displays a T, P, or C indicating a total, protected, or
computed group, and an M for a member of a group. When groups are members
of other groups a multi-level hierarchy is defined.

By default, groups appear at the end of a dimension. If you want to specify
where the group is to be placed, you can add an item for the group.
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Adding and Deleting Items
The Insert Item dialog box allows you to create a new coded item for a
dimension.

À To add an item

1. Select the dimension that you want to add an item to.

2. Position the cursor on the item that is to be before or after the new item.

3. From the Item menu, choose Insert.

 The Insert Item dialog box appears.

 

4. In the Item Code box, enter the code for the new item.

5. In the Where to Insert area, select the option that indicates where the new
item should be placed.

6. Click OK.

 The new item displays in the current view.

À To delete an item

 Warning:   Once an item is deleted, you cannot retrieve it.

1. Select the item to be deleted.

2. From the Item menu, choose Delete Item.

 You are prompted to confirm the deletion.

3. Click OK.

 Note:  If you delete an item that belongs to a group, the values of the group
total do not change until you rerun the Calculate command. Refer to “To
calculate group totals” on page 126.
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Defining a Group

À To define a total or a protected group

1. Select the items in the dimension that you want to become members of the
group. To select non-adjacent items, refer to “To select multiple non-
adjacent headings” on page 41.

 Tip:  If you want to create a group that is made up of all items in a
dimension, make that dimension active and leave all items unselected.

2. From the Item menu, choose Define Group.

 The Define Group dialog box appears.

 

3. In the Group Code box, enter a unique name or item code to represent the
group.

4. In the Group Type area:

Select To

Total sum the data values of the members of the group.

Protected define a group hierarchy while leaving the data as is (i.e., the data
will not be affected by the Calculate command).

5. Click OK.

 If you are defining a total group, you are prompted to proceed with the
calculation of the groups.

Click To

Yes calculate all groups.

No calculate groups at a later time.
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 The new group code appears in the current view. The status bar displays a T
or P indicating the group type.

Next Steps:

To calculate group totals, if not already calculated, proceed to “Calculating
Group Totals” on page 125.

To add labels to the group, refer to “To add labels manually” on page 129.

À To define a computed group

1. From the Item menu, choose Define Group.

 The Define Group dialog box appears.

2. In the Group Code box, enter a unique name or item code to represent the
group.

3. Select the Computed option button.

4. In the Formula box, enter a expression to describe how the new group is to
be calculated.

 Tip:  To include existing items in your formula, double-click the
appropriate item name in the Items box or highlight the item name you

want to include and click  (Insert).

 The outlined syntax should be followed when constructing your formula:

• The following arithmetic operators may be used: +(add), -(subtract),
*(multiply), /(divide), and ^(raise to the power).

• The following relational operators may be used: <(less than), <=(less
than or equal to), =(equal to), >=(greater than or equal to), >(greater
than), and <>(not equal to).

• In an expression, ^ is evaluated before * and / which are in turn
evaluated before + and -. Otherwise, evaluation proceeds in a left to
right order.

• Round brackets ( ) are used to alter the order of execution.

• If, then, else, and endif constructs are used to create more complex
formulae. All four words (if, then, else, endif) must be included in your
constructs.

• Square brackets must be used around item names containing special
characters (e.g., blanks or _ ). For example, [Field One].

5. Click OK.

 You are prompted to proceed with the calculation of the groups.
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Click To

Yes calculate all groups.

No calculate groups at a later time.

 The new group code appears in the current view. The status bar displays a
C indicating the group type.

Next Steps:

To calculate group totals, if not already calculated, proceed to “Calculating
Group Totals” on page 125.

To add labels to the new group, refer to “To add labels manually” on page 129.

Selecting the Members of a Group
An item that is a member of a group is represented by the letter M in the status
bar. Select Group is used to confirm a group's members or to quickly select the
items that belong to a group.

À To select a the members of a group

1. Select the group item whose members you want to select.

2. From the Item menu, choose Select Group.

 The items that are members of the group are highlighted in the current
view.

Removing a Group
When removing a group, the item and its data values are not deleted. Only the
group definition is removed.

À To remove a group

1. Select the item whose group definition you want to remove.

2. From the Item menu, choose Remove Group.

 The group type indicator is removed from the status bar.

Calculating Group Totals
Tip:  When calculating group totals, it saves time to define all groups in all
dimensions before you run the Calculate command.
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À To calculate group totals

1. From the View menu, choose Calculate.

 The Browser calculates and displays the group totals.

Fields
Fields are the components of a dimension. All fields of a dimension can be
displayed in a dimension view. You can add, edit, delete, hide or show fields.

A field can be assigned a language so that, in a multilingual table, the
appropriate language of the dimension displays.

Fields can contain codes that uniquely identify an item, labels that describe an
item, and coded links to a map file.

Adding a Field
Before you can add labels to a dimension, you must first add a field.

À To add a field to a dimension

1. Select the dimension that fields are to be added to.

2. Do one of the following:

• Click the Display Fields button on the toolbar.

• From the View menu, choose Dimension.

 The dimension view appears.

3. From the Dimension menu, choose Add Field.

 The Add Field dialog box appears.

 

4. In the Field Name box, enter the name that you want to give the new field.
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 Note:  If you are adding a field to import labels, the field name must be
identical to the field name in the import file.

5. In the Field Type box, select Label.

6. If you are in a multilingual table, enter or select the language of the field
you want to add.

 Note: If you select a language other than that of the current table, the field
is added to the appropriate table view and can only be seen when you are in
that table or dimension view of that language.

7. Do one of the following:

• Select the Display as Data Label check box to display this field as a
label in the table view.

• Clear the Display as Data Label check box to prevent Browser users
from seeing this field in the table view.

8. Click OK.

 The field is added to the dimension view.

Next Steps

If you are adding a field that is going to contain labels, proceed to “Labels” on
page 129.

Deleting a Field

À To delete a field from a dimension

 Important:  You cannot delete the Code field. The Browser needs the Code
field to uniquely identify each item in the dimension.

1. Select the dimension that contains the field you want to delete.

2. Do one of the following:

• Click the Display Fields button on the toolbar.

• From the View menu, choose Dimension.

 The dimension view appears.

3. Position the cursor in the field to be deleted.

4. From the Dimension menu, choose Delete Field.

 You are prompted to confirm the deletion.

5. Click OK.
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Editing a Field

À To edit a field in a dimension

1. Select the dimension containing the field you want to edit.

2. Do one of the following:

• Click the Display Fields button on the toolbar.

• From the View menu, choose Dimension.

 The dimension view appears.

3. Position the cursor in the field to be edited.

4. From the Dimension menu, choose Edit Field.

 The Edit Field dialog box appears.

 

5. In the Field Name box, enter a new field name.

6. If your table is multilingual, in the Language box, enter or select the
language of the field.

7. Modify the Display as Data Label and Band Field options as required.

8. Click OK.

Hiding and Showing Fields
You can control which fields are displayed in the table and dimension views by
hiding and showing fields.

À To hide or show fields

1. Select the dimension containing the fields you want to hide or show.

2. From the Dimension Menu, choose Hide/Show Fields.

 The Hide/Show Fields dialog box appears.
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3. In the Select fields to be shown box, select the fields you want to be
visible, and deselect the fields that are to be hidden.

4. Do one of the following:

• Click Save to save the selections for future sessions.

• Click OK to save the selections for the current session only.

Labels
Labels can be entered manually or imported from a comma-separated value file,
or a dimension definition file. You must prepare a comma-separated value file
before importing labels into a dimension view.

Adding Labels Manually

À To add labels manually

1. Select the dimension you want to add labels to.

2. Do one of the following:

• Click the Display Fields button on the toolbar.

• From the View menu, choose Dimension.

3. If required, add a label field to the dimension that requires labels. Refer to
“To add a field to a dimension” on page 126.

4. In the label field, select the cell that requires a label. Enter the label and
press Enter.

 Tips:  You can set the action of the cursor on pressing Enter. To move the
cursor down instead of across after pressing Enter, from the Window menu
choose Preferences, select Cursor Down after Cell Edit.
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 To edit a label after it has been entered, select the label and press F2. The
item is highlighted. Make any required changes and press Enter.

5. Repeat Step 4 for each cell in the field that requires a label.

Next Steps:

To make this label field the default label, proceed to “Setting the Default Label
Field” on page 133.

Preparing Labels in Comma-Separated Value Format
Another way to import labels into a dimension, is to prepare a comma-separated
value file and import it into the field of a dimension view. Comma-separated
value files are prepared outside of Beyond 20/20 and must have a .csv
extension.

The comma-separated value file you create must contain a field whose values
match those in a field that is already in the dimension view. This field is called
the lookup field and is normally the Code field. The first line of the comma-
separated value file should be the case sensitive names of the fields in the
dimension, one of which must be the lookup field.

For each row in the comma-separated value file, the Browser takes the field that
you identify and uses it to search for a match in the lookup field of the
dimension. When the Browser finds a match, it takes the corresponding label
from the same row of the comma-separated value file and places it in the
matching fields of the dimension that is being updated.

You can use any editor or spreadsheet to create a comma-separated value file.
These files contain the same number of fields in each row entry (as specified by
the first line), delimited by commas, and each entry has a carriage-return and
linefeed character at the end of it. Most spreadsheets packages allow you to
save active spreadsheets in comma-separated value format.

You can import more than one set of labels by including several sets in the
comma-separated value file.
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Here is an example of a comma-separated value file:

Code,English Desc
NA,North America
CA,Canada
MA,Maritimes
QU,Quebec
ON,Ontario
TO,Toronto
WC,Western Canada
US,United States
WU,Western US
CU,Central US
NU,Northeast US
NY,New York
SU,Southeast US
MX,Mexico
NM,North Mexico
CM,Central Mexico
MC,Mexico City
SM,South Mexico

À To prepare a comma-separated value file from a spreadsheet

1. In the first row of your spreadsheet, enter the field names as they appear in
the dimension view of the field you are importing labels into (i.e., the
lookup field).

 Example: Enter Code in cell A1 and English Desc in cell B1.

2. In the Code column, enter the complete set of item codes for the dimension
you are importing labels into.

3. In the Label column, enter the corresponding labels.

4. From the File menu, choose Save As.

 The Save As dialog box appears.

5. In the File Name box, enter or select the file you want to save.

 If you do not see the file you want, select a different drive or directory to
locate the file.

6. Select comma-separated value (*.csv) as the file type.

7. Click OK.
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Importing Labels
You can bring labels into a field of a dimension view from a comma-separated
value file, or a dimension definition file.

Before using the Import command, you must first prepare a file for import. For
information on preparing a .csv file, refer to “To prepare a comma-separated
value file from a spreadsheet” on page 131.

In all cases, it is important to remember that the lookup field name (i.e., the
field name in the dimension containing values) must match a field name in the
input file (i.e., the comma-separated value file containing the labels to be
imported).

The Import dialog box allows you to enter the name of the file that contains the
labels, and to specify the lookup field, and import file options.

À To import labels

 Note:  You must be in a dimension view to import labels.

1. If required, add a label field to the dimension that requires labels. Refer to
“To add a field to a dimension” on page 126.

 Note:  The new field name in the dimension must be identical to the field
name in the input file that contains the labels you are importing.

2. From the File menu, choose Import.

3. Do one of the following:

• In the Input Filename box, enter the path and file name of the file to
import.

• Click Browse to locate and select the file to import.

4. In the Lookup Field box, select the field the Browser should use to match
items with those in the input file.
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5. In the Import Options area:

Select If you want the Browser to

Add New Codes add new codes from the input file into the dimension.

Case Sensitive on Codes import only those items that are an exact match to the
codes in the lookup field.

Use Windows Character
Set

import the file as ANSI standard characters rather
than OEM (DOS) characters.

6. Click OK.

 The label field is filled with labels for those items in the input file that are
also in the dimension.

Next Steps:

To make this label field the default label, proceed to “Setting the Default Label
Field” on page 133.

Setting the Default Label Field
When you set a field as the default label field, you are controlling which labels
are seen when a table is first opened.

À To set the default label field

1. Select the dimension you want to set default label fields for.

2. Do one of the following:

• Click the Change Labels button on the toolbar.

• From the Dimension menu, choose Change Labels.

 If you save the view, the next time you open this table, this dimension
displays the set of labels you selected.

 To save the view, refer to “To save the current view” on page 134.

Saved Views
A saved view is a particular view of a table that is stored in the table file (*.ivt)
and defines how the table is displayed. It is a personalized snapshot of a table
that allows you to quickly recall a specific table layout without having to
redefine its attributes.
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A Beyond 20/20 view consists of the following:

Attribute Description

Language The language in which to display the table.

Dimension
Information

For each dimension, the dimension information
consists of: the sort order of items, the items that are
shown, the first item to display, the label field to use
for each language in the table, the width of the row
dimension label, and the width of the dimension bar
dimension label.

Row Dimensions The list of row dimensions in the order in which they
are nested.

Column Dimensions The list of column dimensions in the order in which
they are nested.

Dimension Bar Dimensions The list of the dimensions in the dimension bar, in
the order (left to right) that they appear on the screen.

Column Width The width of the data columns.

Decimals The number of decimals to display.

Time Series Information The time series type, periodicity, method, and
number of periods.

Fiscal Month The current fiscal month.

À To save the current view

Note:  To permanently change the default view of a table, you must have
permission to modify the table.

1. Arrange the table information in the layout you wish to save.

2. From the View menu, choose Save.

 The next time you open the table, the saved view will automatically appear.

Note:  If you are in a read-only table, if you do not want to permanently modify
the default view of the table, or if you wish to save multiple views of the same
table, you can save the current view without affecting the original view of the
table.

1. Arrange the table information in the layout you wish to save.

2. From the File menu, choose Save As.

 The Save As dialog box appears.

3. In the File Name box, enter the name of the file you want to save.

4. If necessary, select a different drive or directory.
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5. Clear the Include Numeric Data check box.

6. Click OK.

 The current view of the table is saved as a new table file.

 Notes:  Data is not saved with the view. When the view is opened from
another table, Beyond 20/20 checks the consistency of the view with the
current table. If consistent, the current table view is replaced with the view
being opened.

 Saved views can be located through the Find dialog box or the Open dialog
box. Refer to “Finding and Opening Tables and Extracts” on page 33.

Next Steps:

To recall a view saved in this fashion, proceed to “To open a saved view” on
page 135.

À To open a saved view

1. From the View menu, choose Open.

 The Open dialog box appears

2. Select the view file you want to open.

3. If you do not see the file you want to open, select a different drive or
directory to locate the file.

4. Click OK.

 Beyond 20/20 checks the consistency of the view with the current table. If
consistent, the current view is replaced with the view being opened.

À To restore the current view to the last saved view

1. From the View menu, choose Reset.

 Any changes you made to the current view are lost and the table view is
restored to the last saved view.

Documenting a Table
Once a table has been created, it is important to document it for future sessions.
To document a table, you should enter a table summary, dimension and item
summaries, and labels.

For information on adding labels, refer to “Labels” on page 129.
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Table Summary
A table summary contains general information about a table and is helpful in
understanding the contents of the table. It can include information about where
the data came from, how it was collected, or the name of people you can
contact who can supply further information and explain any anomalies in the
data.

The Summary dialog box can be accessed at any time by choosing the File
command from the Summary cascade menu in the Edit menu.

The Summary dialog box allows you to enter general information about the
table.

À To create a table summary

1. From the Edit menu, choose Summary, then File.

 The Summary dialog box appears.

2. Enter the following information:

Box Summary information

Title A description of the table.

Category A subject area classification for the table.

Author The author of the table.

Keywords Words a that can be entered to search for the table.

Notes Any notes you wish to associate with the table that may make the
table more understandable. If you wish, you can enter the notes
in HTML format.

3. Click OK.
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Dimension Summary
A dimension summary contains textual information, or notes, about a
dimension.

À To enter a dimension summary

1. Select the dimension you want to add notes to.

2. From the Edit menu, choose Summary, then Dimension.

 The Dimension Summary dialog box appears.

3. Enter any notes you wish to associate with the dimension that may make
the dimension more understandable. If you wish, you can enter the notes in
HTML format.

4. Click OK.

 The dimension name in the tile is underlined to indicate that summary
information exists.

Item Summary
An item summary contains textual information, or notes, about a specific item
within a dimension. It may explain any anomalies in the data, or give specific
details about the item.

À To enter an item summary

1. Select the item you want to add notes to.

2. From the Edit menu, choose Summary, then Item.

 The Item Summary dialog box appears.

3. Enter any notes for you wish to associate with the item that may make the
item more understandable. If you wish, you can enter the notes in HTML
format.

4. Click OK.

The item name is underlined to indicate that summary information exists.





Glossary

active

Currently selected. Any window and/or object that is currently
selected is active. When an object is active, the Browser
highlights it to show that it is selected. Browser commands
affect the active object.

aggregate

To calculate a single data value which summarizes the data
associated with more than one consecutive period of time.

ANSI character set

The American National Standards Institute 8-bit character set.

application

A computer program such as a word processing program or
spreadsheet program.

application window

The window that contains your workspace, the menu bar, and
(if available) a toolbar. Document windows are displayed in
the workspace.

band

A range of numeric values associated with a numeric source
field.

base frequency

The actual frequency at which the data is recorded in the
table.
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category

A name that is used to classify similar Beyond 20/20 tables,
extracts and source fields of an extract according to subject.

cell

The smallest unit of data in a table view. The number that is
displayed in a cell is common to all of the items on display,
including the items in the Dimension bar and the intersecting
items in the column and row dimensions.

check box

A small square box that is displayed beside an option in a
dialog box. It can either be selected or cleared. When an
option is selected, a check mark appears in the check box.

Clipboard

A temporary storage area for transferring data between
documents and applications. The Copy command is used to
move data to the Clipboard.

code

A symbolic value that uniquely identifies an item. A code can
be an abbreviation, or a combination of numbers and letters.

column

A sequence of numeric values related to the column
dimension of a table view. A column contains one value for
each row in the view.

column dimension

The dimension whose items are currently on display in the
columns of a table view.

Control-menu box

The box to the left of a window’s title bar. It contains the
Control menu, which provides commands for manipulating
the window. To open the Control menu, click on the Control-
menu box.
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Control Panel

The Windows program that controls the settings for your
monitor. You can run the Control Panel from the Main
program group in the Program Manager.

current directory

The directory from which you are currently opening files
from, or saving files to. The path in the Open dialog box
names the current directory.

cursor

The border that highlights the active cell in a table view. You
can move the cursor from one cell or item to the next using
the Previous Item and Next Item buttons.

data type

A classification of the data in a source field. The data in a
source field is classified as either "Coded" or "Numeric". A
coded source field contains one code for each record of the
source file, and each code has a specific meaning. An example
of a coded field is Sex (Code ’1’=Male, Code ’2’=Female). A
numeric source  field contains a numeric value for each record
of the source file and each value can be different. An example
of a numeric field could be ’Salary’.

defaults

The (start up) options that are preselected in the Browser
software. You can override the default settings by specifying
new ones after you start the Browser for the first time.

desktop

The background of the screen, on which all application
windows and icons appear.

dialog box

A window that the Browser displays to request information.
Dialog boxes have options you can select to influence the
outcome of a command.
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dimension

An aspect of the data (such as sex or region), which is broken
down into one or more items (such as male and female, or
Canada and U.S.). A dimension can be displayed in a
dimension tile, or along the columns or rows of a table view.

dimension definition file

A file containing the codes and labels associated with either a
dimension of a table or a source field of an extract. If related
to a source field, this file also contains all the data associated
with the source field. These files can also contain complete
classification systems for the dimensions or source fields they
represent. These files have an (.ivd) extension.

dimension view

A window which shows all codes and labels that are
associated with a dimension of a table or with a source field of
an extract.

dimmed

Unavailable or disabled. A dimmed button or command is
displayed in gray to show that it cannot be selected.

directory

A named area in the file storage structure on a disk.
Directories are used to organize groups of related files. A
directory can contain subdirectories.

display frequency

The selected interval of time between consecutive items on
display in a time series dimension.

document window

A window inside the application window. A document window
can contain a table view, a dimension view, a chart view, or a
map view.
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drag

To move an object on the screen from one area to another, or
to select multiple choices or objects from a dialog box option
or a view.

To drag, position your cursor over the object you want to
relocate or select. Click on and hold the left mouse button,
then move the mouse. As the mouse is moved, either the
object is repositioned on the screen, or multiple choices/items
are selected.

drive

A device that is used to store and retrieve the information on a
disk. Letters (for example, C: and H:) are used to identify the
drives that are available on your computer and/or network.

drop

To release the left mouse button after an object has been
repositioned on the screen. When the button is released, the
object is displayed wherever the mouse pointer is currently
pointing.

export

To extract data from an existing file format and translate it
into a different format.

extension

The period character and up to three characters at the end of a
file name. An extension can identify the kind of information a
file contains. For example, Beyond 20/20 tables are named
with the ‘.ivt’ extension.

extract

A set of files created by the Beyond 20/20 Builder which is
optimized to create rapid table creation with the Beyond 20/20
Browser. An extract is comprised of one extract file (.ivx) and
one dimension definition file (.ivd) for each source field
associated with the extract.
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extract file

An ASCII file containing summary documentation about the
extract as well as references to each of the dimension
definition files associated with each source field related to the
extract.

field

A set of codes or a set of labels for all of the items in a
dimension.

file format

The way information is structured inside a file. To access the
data in a file, an application must be able to read and interpret
the file format.

file name

The name of a file. A file name can contain up to eight
characters, followed by an optional file name extension.

font

The size and common design attributed to a set of letters,
numbers, punctuation marks, and symbols.

group

An item in a dimension that has an underlying hierarchical
structure.

highlight

To make an object on the screen stand out by displaying it in
reverse video or in color. Highlighting indicates that an object
is selected, and that it will be affected by the next command.

icon

A graphic object that represents an application, a document, or
a minimized window.

import

To bring new data into an existing file format.
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index numbers

The sequential numbers in the column on the left side of the
dimension view window. There is one index number for each
item in the dimension.

item

An element of a dimension. An item can be identified by its
unique code. It may have one or more labels assigned to it.

keyword

A word that you can search for (using the Search Components
dialog box) to locate relevant tables quickly.

label

A word or series of words that name a person, object, or place.
A label could also be a time value (such as day, month,
quarter, or year), a symbolic value (such as a combination of
letters and numbers, or an abbreviation), or a unit of
measurement.

local

Directly connected to one of the ports on your computer.

maximize

To enlarge a window to its maximum size, or to turn the
selected icon into the active window by choosing the
Maximize command from the icon’s Control menu.

minimize

To collapse a window or a document into an icon by choosing
the Minimize button, or by choosing the Minimize command
from the window’s Control menu.

mouse pointer

The object on the screen that follows the movement of a
mouse and indicates which area of the screen will be affected
when you click on the mouse button.
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multilingual table

A table that has more than one language associated with it.
Multilingual tables are prepared by the Builder user who
determines which languages are associated with the table.

nest

To display more than one dimension along the columns or
rows in a table view.

network

A group of computers and devices which are connected so that
they can exchange information and share drives and printers.

object

A general term that refers to any graphic on the screen you
can drag.

option

A choice in a dialog box.

path

The route the operating system follows through the directory
structure to locate a directory or a file.

profile

A profile is a user-defined collection of items for a dimension.
These items can be selected or shown when the dimension is
selected and the profile is loaded.

public directory

The directory into which the Beyond 20/20 tables were copied
when the Beyond 20/20 software was installed. Changing the
path in the Find dialog box overwrites the path to the public
directory.

read-only file

A file that cannot be changed.
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recode

The action of assigning one or more codes in an existing
source field to one or more new items.

record

The basic logical unit of a data base containing all source
fields.

row

A sequence of numeric values related to the row dimension of
a table view. A row contains one value for each column in the
view.

row dimension

The dimension whose items are currently on display in the
rows of a table view. More than one dimension can be nested
in the row dimension area.

saved view

A particular view of a table that is stored in the table file and
defines how the table is displayed.

scroll

To move through a window, a document, or the choices in an
option to see a part of a file or part of a list that is currently
not visible.

search result

The list of tables or items that match the search criteria you
specify.

select

To click on an object or on a choice so that a subsequent
action can be carried out on it.

session

The time between when you start the Browser and when you
quit the Browser.
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shortcut key

A key combination that can be used as an alternative to the
mouse for choosing a command from a menu.

shortcut menu

Any menu that is displayed in a document window when the
right mouse button is pressed.

source field

A subset of a record describing one complete variable
comprised in the record. For example, Sex and Salary could
be source fields of a human resources data base record.

subdirectory

A directory within another directory.

switch

To exchange the position of one dimension with another.

table

An integrated presentation of multi-dimensional data and
descriptive text.

table file

A file that contains descriptive components, dimension field
information, and data values. When the file is opened, the
Browser presents the data in a table view.

table view

The main display of a table. It is a window which shows the
dimensions of a table, along with the cells and corresponding
data from the source file.

tile pattern

A way of arranging open windows so that no windows overlap
but all windows are visible.
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weight

A number indicating the logical number of times this record of
the sample is to be included in a tabulation to obtain estimates
of measures for the population.

Windows application

Any application that has been designed to run after Microsoft
Windows has been started.

worksheet

A working copy of a table. Data in a worksheet may be
manipulated without affecting the original table. Any table
operations may be made on the worksheet even if the original
table is read-only.

workspace

The area of the application window where you work with
documents. You can move document windows anywhere
within the workspace.
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horizontal axis 73
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legend 72
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linking dimensions 73
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Reset (View) 135
Restore 94
Reverse 43
Save (View) 134
Save As 67, 69, 117, 131, 134
Save Extract As 119
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Search 10, 51, 53, 54
Select All 41
Select Group 125
Set Active Dimension 40
Set Weight Field 114
Show 42
Show All 43
Sort 10, 55
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Constraint Field dialog box 111
Context sensitive help 4
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User’s guide 2
Copy

chart 84
command 69, 84, 95
data to another application 69
map 94

Ctrl key 35, 41, 99, 103, 112

D

Data
changing the display 59
copying to another application 69
displaying decimals 60
displaying values in a map 86
displaying zeros 60
exporting to a different file format 68
importing 66
importing tables 66
loading data into a table 116
missing or unavailable values 63
printing 69
saving 67
saving data into a new table 67
selecting aggregation method 60
updating tables 66

Data values
cities in a map 91
displaying in a map 90

Decimals
command 60
displaying 59

Define Bands
command 104
dialog box 104

Define Derived Field
command 107
dialog box 107

Define Group
command 123, 124
dialog box 123

Define Recode
command 103
dialog box 102

Delete Field command 127
Delete Item command 122
Delete Source Field command 118
Derived fields

constructs
else 106
endif 106
if 106
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then 106
Dimension

command 56, 126, 127, 128, 129
Dimension (Summary) command 137
Dimension bar 12
Dimension command 10, 45
Dimension definition file  8

importing labels 132
recreate 118

Dimension profiles 48
creating 48
deleting 50
importing 49
loading 49
selecting 49

Dimension tiles
positioning 108
selecting 40
use the keyboard to move 44
using the keyboard to select 40

Dimension view
displaying 45

Dimensions
adding labels 126
chart operations 73
creating a new one using distributions 64
customizing 102
deleting fields 127
displaying a dimension view 45
displaying field information 46
editing fields 128
entering summaries 137
exporting data 68
geographic 85
linking and unlinking in a chart 73
moving a tile using the keyboard 44
nesting 43
positioning tiles for 108
resizing tiles and headings 15
saving a subset of 48
searching data 52
searching time series 54
selecting 40
selecting a dimension in a chart 73

selecting items 41
setting a color for tiles and headings 14
summaries 58
switching 43
switching and nesting using the keyboard

44
switching in charts 74
time series options 60
using Active Dimension box to select 40
working with 45

Display Chart button 10, 71
Display Fields button 10, 45, 56, 126, 127,

128, 129
Display Map button 10, 85
Distributions

calculating 64
command 64
dialog box 64

Document window 11
Active Dimension box 9
cascading 15
closing 16
column dimension area 12
dimension bar 12
extract 11
how to cascade 16
objects in 11
Previous and Next Item buttons 9
row dimension area 12
source field bar 12
status bar 13
table 11
tiling 15, 16
toolbar buttons 9

Documenting
tables 135

E

Edit Axis dialog box 82
Edit Field

command 128
dialog box 128

Edit Unit Item
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command 109
dialog box 109

Elements
chart 72
map 86

End
a Browser session 32

Export
data 68
extract 119

Extensions
*.csv 68
*.dbf 68
*.dbf 119
*.ivd 8
*.ivp 8
*.ivt 8
*.ivx 8
*.sas 119
*.sps 119
*.tsd 68
*.txt 68
*.wk1 68
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view 98
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exporting 119
file 8
finding by category 33
opening 37
recreating 118
save extract as 113
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code 46
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importing labels 132
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manually add 129
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searching 51
setting the default label 133
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.dbf 68, 119
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.tsd 68
.txt 68
.wk1 68
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Files
comma-separated value 131
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profile 8
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Find
button 9, 33
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command 9, 33
dialog box 34

Find Source Field
command 98
dialog box 99

Find Source Field Search dialog box  100
Fiscal Year

command 63
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dialog box 63

Font
changing in a chart 81
dialog box 81

Footnotes
displaying in a chart 79
displaying in a map 90
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chart 80
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button 10, 116
command 10, 116
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computed group 121
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if 124
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Headings
resizing 15
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context sensitive 4
on-line 3
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Hide/Show Fields
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dialog box 129
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Import
command

import labels 132
updating tables 66

dialog box 66, 132
labels 132

Import Dimension Profile dialog box  49
Import Profile command 49
Insert command 122
Insert Item

dialog box 122
Item (Summary) command 137
Items

adding 122
browsing 39
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displaying an item that defines a group 48
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displayed 43
entering summaries 137
exporting data 68
hiding and showing 42
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Keyboard
key combinations and sequences  3
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Label field
searching 51
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adding 126
adding manually 129

displaying alternate 46
displaying cities in a map 91
displaying in a map 90
importing 132
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abbreviation in status bar 13
adding to a table 116
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setting the default 116
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moving in a chart 81
moving in a map 94

Line charts 78
Line Marker charts 78
Load Profile

command 49, 50
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Map command 10, 85, 88
Map Options
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changing the layout 92
copying 94
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displaying 85
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Preferences
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setting the color for tiles and headings 15
setting the selection color 15
sort source field tiles alphabetically 118

Previous Item button 39
Print
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setup options 70
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selecting 90
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copying 69
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Save (View) command 134
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Source field tiles 117
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